"Alt Gr" button does't work - Debian

This is a discussion on "Alt Gr" button does't work - Debian ; Dear all, I have installed Debian 3.1 on my Toshiba Tecra M2 Laptop. It seems to work everything, but I have a small trouble with the combined chars (eg: "ALT Gr + @"). The keyboard is Italian and it seems ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: "Alt Gr" button does't work

  1. "Alt Gr" button does't work

    Dear all,

    I have installed Debian 3.1 on my Toshiba Tecra M2 Laptop.
    It seems to work everything, but I have a small trouble with the combined
    chars (eg: "ALT Gr + @").

    The keyboard is Italian and it seems to be configurated in right way, but
    "AltGr" doesn't work. Any suggestions?

    Thank you.

    Oddbyte


    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: "Alt Gr" button does't work

    Dear Gustavo,

    thanks a lot for your answer.

    I changed the file /etc/X11/XF86Config-4 in the following mode:
    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "keyboard"
    Option "CoreKeyboard"
    Option "XkbRules" "x.org"
    Option "XkbModel" "pc102"
    Option "XkbLayout" "it"
    #old
    #Option "XkbRules" "xfree86"
    #Option "XkbModel" "pc104"
    #Option "XkbLayout" "it"
    #Option "XkbVariant" "it"
    EndSection

    But it doesn't work, yet.
    Any suggestion?

    Thank you.
    Oddbyte


    On Thursday 06 October 2005 18:23, gustavo halperin wrote:
    > Check your /etc/X11/XF86Config-4, for the keyboard input device, do you
    > have some thing
    > like this:
    > /**********************/
    > /Section "InputDevice"
    > Identifier "Generic Keyboard"
    > Driver "keyboard"
    > Option "CoreKeyboard"
    > Option "XkbRules" "x.org"
    > Option "XkbModel" "pc102"
    > Option "XkbLayout" "it"
    > EndSection
    > /*************************/
    > /
    > Gustavo
    >
    > Oddbyte wrote:
    > >Dear all,
    > >
    > >I have installed Debian 3.1 on my Toshiba Tecra M2 Laptop.
    > >It seems to work everything, but I have a small trouble with the combined
    > >chars (eg: "ALT Gr + @").
    > >
    > >The keyboard is Italian and it seems to be configurated in right way, but
    > >"AltGr" doesn't work. Any suggestions?
    > >
    > >Thank you.
    > >
    > >Oddbyte



    --
    To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread