Bug#420185: linux-image-2.6.20-1-686: pseudo terminals not created properly - neither is /dev/ttyzf - Debian

This is a discussion on Bug#420185: linux-image-2.6.20-1-686: pseudo terminals not created properly - neither is /dev/ttyzf - Debian ; Package: linux-image-2.6.20-1-686 Version: 2.6.20-2 Severity: important I have an Intel DG965SS motherboard. For some time I have had to run a hand compiled version of the linux kernel (2.6.19) because updates to Sid were held back until Etch was released. ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Bug#420185: linux-image-2.6.20-1-686: pseudo terminals not created properly - neither is /dev/ttyzf

  1. Bug#420185: linux-image-2.6.20-1-686: pseudo terminals not created properly - neither is /dev/ttyzf

    Package: linux-image-2.6.20-1-686
    Version: 2.6.20-2
    Severity: important

    I have an Intel DG965SS motherboard. For some time I have had to run
    a hand compiled version of the linux kernel (2.6.19) because updates
    to Sid were held back until Etch was released. This was because it
    was necessary for the AGPGART id to be recognised. I used the 2.6.18
    debian config for this build.

    Now that 2.6.20 has come out, I have attempted to switch back to the
    standard debian kernel but if I load up that, two things appear to
    happen

    bootlogd fails with failure with a problem with /dev/ttyzf, and

    I whenever I try and run anything that requires a psuedo tty it
    fails (so for instance I cannot ssh into the machine, nor can I run
    terminals under X).

    /dev/ptmx exists and has the correct permissions.

    Rebooting back to 2.6.19 (as I am running now) without any other
    changes fixes the problem

    -- Package-specific info:

    -- System Information:
    Debian Release: lenny/sid
    APT prefers unstable
    APT policy: (500, 'unstable')
    Architecture: i386 (i686)

    Kernel: Linux 2.6.19 (SMP w/2 CPU cores)
    Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
    Shell: /bin/sh linked to /bin/bash

    Versions of packages linux-image-2.6.20-1-686 depends on:
    ii initramfs-tools [linux-initra 0.87b tools for generating an initramfs
    ii module-init-tools 3.3-pre4-2 tools for managing Linux kernel mo

    Versions of packages linux-image-2.6.20-1-686 recommends:
    ii libc6-i686 2.5-2 GNU C Library: Shared libraries [i

    -- debconf information:
    shared/kernel-image/really-run-bootloader: true
    linux-image-2.6.20-1-686/postinst/depmod-error-initrd-2.6.20-1-686: false
    linux-image-2.6.20-1-686/postinst/old-initrd-link-2.6.20-1-686: true
    * linux-image-2.6.20-1-686/preinst/already-running-this-2.6.20-1-686:
    linux-image-2.6.20-1-686/preinst/failed-to-move-modules-2.6.20-1-686:
    linux-image-2.6.20-1-686/preinst/overwriting-modules-2.6.20-1-686: true
    linux-image-2.6.20-1-686/postinst/create-kimage-link-2.6.20-1-686: true
    linux-image-2.6.20-1-686/preinst/abort-overwrite-2.6.20-1-686:
    linux-image-2.6.20-1-686/preinst/lilo-has-ramdisk:
    linux-image-2.6.20-1-686/prerm/removing-running-kernel-2.6.20-1-686: true
    linux-image-2.6.20-1-686/postinst/bootloader-test-error-2.6.20-1-686:
    linux-image-2.6.20-1-686/preinst/bootloader-initrd-2.6.20-1-686: true
    linux-image-2.6.20-1-686/postinst/bootloader-error-2.6.20-1-686:
    linux-image-2.6.20-1-686/preinst/elilo-initrd-2.6.20-1-686: true
    linux-image-2.6.20-1-686/preinst/initrd-2.6.20-1-686:
    linux-image-2.6.20-1-686/preinst/lilo-initrd-2.6.20-1-686: true
    linux-image-2.6.20-1-686/postinst/kimage-is-a-directory:
    linux-image-2.6.20-1-686/postinst/depmod-error-2.6.20-1-686: false
    linux-image-2.6.20-1-686/postinst/old-dir-initrd-link-2.6.20-1-686: true
    linux-image-2.6.20-1-686/postinst/old-system-map-link-2.6.20-1-686: true
    linux-image-2.6.20-1-686/prerm/would-invalidate-boot-loader-2.6.20-1-686: true
    linux-image-2.6.20-1-686/preinst/abort-install-2.6.20-1-686:


    --
    To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Bug#420185: marked as done (linux-image-2.6.20-1-686: pseudo terminals not created properly - neither is /dev/ttyzf)


    Your message dated Wed, 21 May 2008 20:23:32 +0200
    with message-id <20080521182332.GT29953@stro.at>
    and subject line Re: linux-image-2.6.20-1-686: pseudo terminals not createdproperly - neither is /dev/ttyzf
    has caused the Debian Bug report #420185,
    regarding linux-image-2.6.20-1-686: pseudo terminals not created properly -neither is /dev/ttyzf
    to be marked as done.

    This means that you claim that the problem has been dealt with.
    If this is not the case it is now your responsibility to reopen the
    Bug report if necessary, and/or fix the problem forthwith.

    (NB: If you are a system administrator and have no idea what this
    message is talking about, this may indicate a serious mail system
    misconfiguration somewhere. Please contact owner@bugs.debian.org
    immediately.)


    --
    420185: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=420185
    Debian Bug Tracking System
    Contact owner@bugs.debian.org with problems


+ Reply to Thread