binNUMUs - all-depends-any - Debian

This is a discussion on binNUMUs - all-depends-any - Debian ; Hi, I know that the git-core package doesn't support binNMUs, and AFAIK there's no convenient way to change that, as it builds arch: all package that depend on the specific arch: any package. http://bugs.debian.org/423041 Loosening the dependencies as suggested in ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: binNUMUs - all-depends-any

  1. binNUMUs - all-depends-any

    Hi, I know that the git-core package doesn't support binNMUs, and AFAIK
    there's no convenient way to change that, as it builds arch: all package
    that depend on the specific arch: any package.

    http://bugs.debian.org/423041

    Loosening the dependencies as suggested in http://wiki.debian.org/binNMU
    isn't a good solution, as it can lead to

    http://bugs.debian.org/425494

    Can I register the package as non-binNMUable anywhere?, it needs a
    sourceful upload anyway.

    http://bugs.debian.org/430128

    Thanks, Gerrit.


    --
    To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  2. Re: binNUMUs - all-depends-any

    Gerrit Pape writes:

    > Hi, I know that the git-core package doesn't support binNMUs, and AFAIK
    > there's no convenient way to change that, as it builds arch: all package
    > that depend on the specific arch: any package.


    > http://bugs.debian.org/423041


    > Loosening the dependencies as suggested in http://wiki.debian.org/binNMU
    > isn't a good solution, as it can lead to


    > http://bugs.debian.org/425494


    The recommendation for cases like this is to use a dependency like:

    git-core (>= 1:1.5.2.2-1), git-core (<< 1:1.5.2.2-2~)

    or a bit looser if the Debian revision won't matter:

    git-core (>= 1:1.5.2.2), git-core (<< 1:1.5.2.3~)

    --
    Russ Allbery (rra@debian.org)


    --
    To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

  3. Re: binNUMUs - all-depends-any

    Gerrit Pape writes:
    > Hi, I know that the git-core package doesn't support binNMUs, and AFAIK
    > there's no convenient way to change that, as it builds arch: all package
    > that depend on the specific arch: any package.
    >
    > http://bugs.debian.org/423041
    >
    > Loosening the dependencies as suggested in http://wiki.debian.org/binNMU
    > isn't a good solution, as it can lead to
    >
    > http://bugs.debian.org/425494


    Is there a reason why a set of dependencies that only allow package
    versions based on the same upstream version to be installed wouldn't
    work? [1]

    Marc

    Footnotes:
    [1] For a package foo-bar, this would mean that deps should be like
    foo-bar (>= 1.2.3), foo-bar (<< 1.2.4~) (or something similiar)
    --
    Fachbegriffe der Informatik - Einfach erklärt
    67: Für mich steht die Kommunikation im Vordergrund
    Ich weiß, daß mein Gateway Mist baut, aber das ist mir egal.
    (Arno Eigenwillig)

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.6 (GNU/Linux)

    iD8DBQFGfOiJmO5zOp3h7rERAmZrAJ40bvb3ePYsijUWb4k9o6 EGKZ7K5QCfSDID
    q0XmPGKdusCaXtha8fCfHlo=
    =RB3N
    -----END PGP SIGNATURE-----

  4. Re: binNUMUs - all-depends-any

    On Sat, Jun 23, 2007 at 11:31:49AM +0200, Marc 'HE' Brockschmidt wrote:
    > Gerrit Pape writes:
    > > Hi, I know that the git-core package doesn't support binNMUs, and AFAIK
    > > there's no convenient way to change that, as it builds arch: all package
    > > that depend on the specific arch: any package.
    > >
    > > http://bugs.debian.org/423041
    > >
    > > Loosening the dependencies as suggested in http://wiki.debian.org/binNMU
    > > isn't a good solution, as it can lead to
    > >
    > > http://bugs.debian.org/425494

    >
    > Is there a reason why a set of dependencies that only allow package
    > versions based on the same upstream version to be installed wouldn't
    > work? [1]


    > [1] For a package foo-bar, this would mean that deps should be like
    > foo-bar (>= 1.2.3), foo-bar (<< 1.2.4~) (or something similiar)


    That'd work. I was hoping, with the increased usage of binNMUs, there's
    something more convenient than changing debian/control by hand. I'll
    now go with
    Depends: git-core (>> ${source:Upstream-Version}, git-core (<<
    ${source:Upstream-Version}-.)
    I think.

    Regards, Gerrit.


    --
    To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

+ Reply to Thread