Hi,

I just upgraded (partialy) to ETCH from Sarge.

but some dependencies did not meet.

when I try e.g.
apt-get install nmap

i get following:


Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
libxft1: Depends: xfree86-common but it is not installable
pm-dev: Depends: xfree86-common but it is not installable
xfonts-100dpi-transcoded: Depends: xfree86-common but it is not
installable
xfonts-75dpi: Depends: xfree86-common but it is not installable
xfonts-75dpi-transcoded: Depends: xfree86-common but it is not
installable
xfonts-base: Depends: xfree86-common but it is not installable
xfonts-base-transcoded: Depends: xfree86-common but it is not
installable
xfonts-scalable: Depends: xfree86-common but it is not installable
xlibs-static-dev: Depends: xfree86-common but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
specify a solution).

then I try:
apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
libfontenc-dev libxfont-dev x11proto-fonts-dev xfonts-100dpi-
transcoded
xfonts-75dpi xfonts-75dpi-transcoded xfonts-base xfonts-scalable
xlibs-static-dev
The following packages will be REMOVED:
libxft1 pm-dev xfonts-base-transcoded xlibs xlibs-dev
The following NEW packages will be installed:
libfontenc-dev libxfont-dev x11proto-fonts-dev
The following packages will be upgraded:
xfonts-100dpi-transcoded xfonts-75dpi xfonts-75dpi-transcoded xfonts-
base
xfonts-scalable xlibs-static-dev
6 upgraded, 3 newly installed, 5 to remove and 189 not upgraded.
1 not fully installed or removed.
Need to get 0B/24.6MB of archives.
After unpacking 8937kB disk space will be freed.
Do you want to continue [Y/n]?

pressing Y
i get at the end:
(Reading database ... 110426 files and directories currently
installed.)
Preparing to replace lm-sensors 1:2.10.1-3 (using .../lm-
sensors_1%3a2.10.1-3_i386.deb) ...
Unpacking replacement lm-sensors ...
/etc/modutils/0keep: line 9: keep: command not found
Error while executing /etc/modutils/0keep, aborting
dpkg: warning - old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
/etc/modutils/0keep: line 9: keep: command not found
Error while executing /etc/modutils/0keep, aborting
dpkg: error processing /var/cache/apt/archives/lm-
sensors_1%3a2.10.1-3_i386.deb (--unpack):
subprocess new post-removal script returned error exit status 1
/etc/modutils/0keep: line 9: keep: command not found
Error while executing /etc/modutils/0keep, aborting
dpkg: error while cleaning up:
subprocess post-removal script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/lm-sensors_1%3a2.10.1-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I really don't understand what it means using .../lm-
sensors_1%3a2.10.1-3_i386.deb (I did not want to install it - I
already installed lm-sensors 1:2.10.1-3

can anybody suggest anything to try to move forward with this.

thanks
chris