regexplorer - Debian

This is a discussion on regexplorer - Debian ; Hello, When I check the packages list on www.debian.org for Etch, I see that "regexplorer" should be available. But when trying to install with aptitude I can not find this package. Should the packages list need to be updated ? ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: regexplorer

  1. regexplorer

    Hello,

    When I check the packages list on www.debian.org for Etch, I see that
    "regexplorer" should be available.

    But when trying to install with aptitude I can not find this package.

    Should the packages list need to be updated ?

    Thanks.
    carex.

  2. Re: regexplorer

    On Mon, 09 Apr 2007 12:10:03 +0000, carex wrote:

    > Hello,
    >
    > When I check the packages list on www.debian.org for Etch, I see that
    > "regexplorer" should be available.
    >
    > But when trying to install with aptitude I can not find this package.
    >
    > Should the packages list need to be updated ?
    >
    > Thanks.
    > carex.


    Etch has now become 4.0
    Why not download the cd/dvd and reinstall? This should refresh everything.

    --
    Neil
    reverse 'r' and'a' - delete 'l' for email

  3. Re: regexplorer

    On Mon, 09 Apr 2007 07:13:34 -0500, Neil Ellwood wrote:

    > On Mon, 09 Apr 2007 12:10:03 +0000, carex wrote:
    >
    >> Hello,
    >>
    >> When I check the packages list on www.debian.org for Etch, I see that
    >> "regexplorer" should be available.
    >>
    >> But when trying to install with aptitude I can not find this package.
    >>
    >> Should the packages list need to be updated ?
    >>
    >> Thanks.
    >> carex.

    >
    > Etch has now become 4.0
    > Why not download the cd/dvd and reinstall? This should refresh everything.
    >


    Sorry but I still do not understand.
    If you have a look now on www.debian.org in "All Debian packages in
    stable" you will see the "regexplorer" package is still present.
    (today 2007-04-09 14h40)
    Etch is installed and running fine BUT I can not find "regexplorer"
    when looking for it with aptitude.

    So, there must be an error somewhere.
    (package missing or deprecated packages list ??)

    Thanks.
    carex.

  4. Re: regexplorer

    On 04/09/2007 07:10 AM, carex wrote:
    > Hello,
    >
    > When I check the packages list on www.debian.org for Etch, I see that
    > "regexplorer" should be available.
    >
    > But when trying to install with aptitude I can not find this package.
    >
    > Should the packages list need to be updated ?
    >
    > Thanks.
    > carex.


    Make sure that your /etc/sources.list has an Etch repository in it. Then
    update the packages list in aptitude.

    What does your /etc/sources.list currently contain?

  5. Re: regexplorer

    On Mon, 09 Apr 2007 21:55:39 +0000, Mumia W. wrote:

    > On 04/09/2007 07:10 AM, carex wrote:
    >> Hello,
    >>
    >> When I check the packages list on www.debian.org for Etch, I see that
    >> "regexplorer" should be available.
    >>
    >> But when trying to install with aptitude I can not find this package.
    >>
    >> Should the packages list need to be updated ?
    >>
    >> Thanks.
    >> carex.

    >
    > Make sure that your /etc/sources.list has an Etch repository in it. Then
    > update the packages list in aptitude.
    >
    > What does your /etc/sources.list currently contain?



    Here my sources.list.
    I do not think there is a problem there.

    deb http://ftp.debian.skynet.be/ftp/debian/ etch main non-free contrib
    deb-src http://ftp.debian.skynet.be/ftp/debian/ etch main non-free contrib

    deb http://security.debian.org/ etch/updates main contrib non-free
    deb-src http://security.debian.org/ etch/updates main contrib non-free

    Are you sure you can get "regexplorer" from an Etch repository ???

  6. Re: regexplorer

    On Apr 10, 9:52 pm, carex wrote:
    > On Mon, 09 Apr 2007 21:55:39 +0000, Mumia W. wrote:
    > > On 04/09/2007 07:10 AM, carex wrote:
    > >> Hello,

    >
    > >> When I check the packages list onwww.debian.orgfor Etch, I see that
    > >> "regexplorer" should be available.

    >
    > >> But when trying to install with aptitude I can not find this package.

    >
    > >> Should the packages list need to be updated ?

    >
    > >> Thanks.
    > >> carex.

    >
    > > Make sure that your /etc/sources.list has an Etch repository in it. Then
    > > update the packages list in aptitude.

    >
    > > What does your /etc/sources.list currently contain?

    >
    > Here my sources.list.
    > I do not think there is a problem there.
    >
    > debhttp://ftp.debian.skynet.be/ftp/debian/etch main non-free contrib
    > deb-srchttp://ftp.debian.skynet.be/ftp/debian/etch main non-free contrib
    >
    > debhttp://security.debian.org/etch/updates main contrib non-free
    > deb-srchttp://security.debian.org/etch/updates main contrib non-free


    Looks ok, exept it should be a space after "^deb" and "^deb-src". But
    if it works, you only have copied it wrong.

    > Are you sure you can get "regexplorer" from an Etch repository ???


    I can't find it with 'aptitude search regexplorer' or 'aptitude search
    reg'
    Could it be this you looking for?

    p visual-regexp - Interactively debug regular
    expressions

    Good luck


  7. Re: regexplorer

    On 04/10/2007 02:52 PM, carex wrote:
    > [...]
    > Are you sure you can get "regexplorer" from an Etch repository ???


    Your sources.list looks okay.

    Regexplorer has been removed from Debian:
    http://www.debian.org/News/weekly/2005/27/

    You might be able to get the source from the a Debian Sarge mirror and
    build it on Etch.

    And although the upstream developer has gone permanently AWOL, the
    pristine source seems to be available here:
    http://regexplorer.sourceforge.net/

  8. Re: regexplorer

    On Wed, 11 Apr 2007 02:30:37 GMT, Mumia W. wrote:

    >> Are you sure you can get "regexplorer" from an Etch repository ???

    > Regexplorer has been removed from Debian:
    > http://www.debian.org/News/weekly/2005/27/


    Ack. Cf. also
    http://packages.qa.debian.org/r/rege...3T220744Z.html

    JFTR: Taking a look at
    http://packages.debian.org/regexplorer
    shows quickly that the packages is only available in
    oldstable (a.k.a. sarge).


    gregor
    --
    .''`. http://info.comodo.priv.at/ | gpg key ID: 0x00F3CFE4
    : :' : debian: the universal operating system - http://www.debian.org/
    `. `' member of https://www.vibe.at/ | how to reply: http://got.to/quote/
    `- NP: Blumfeld: Wellen der Liebe

+ Reply to Thread