Apt-get >> bus error - Debian

This is a discussion on Apt-get >> bus error - Debian ; Hi I'm using Debian sid, kernel 2.4.27 and yesterday I made an apt-get smart-upgrade with synaptic as usual. Synaptic downloaded several packages and when it opened the console window and started the upgrade, something failed: Preconfiguring packages.... Failled to aplly ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Apt-get >> bus error

  1. Apt-get >> bus error

    Hi

    I'm using Debian sid, kernel 2.4.27 and yesterday I made an apt-get
    smart-upgrade with synaptic as usual. Synaptic downloaded several
    packages and when it opened the console window and started the upgrade,
    something failed:

    Preconfiguring packages....
    Failled to aplly all changes.....

    And no error!!!

    Then I did an apt-get clean, apt-get upgrade with console:

    Julinix:~# apt-get upgrade
    A Ler Listas de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Os seguintes pacotes serão mantidos em suas versões actuais:
    f-spot swf-player
    Os seguintes pacotes serão actualizados:
    apt apt-utils binutils bsdutils debconf debconf-i18n debconf-utils
    fluxbox
    grub iamerican ibritish ispell java-gcj-compat libglib2.0-0 libpoppler0c2
    libpoppler0c2-glib libslang2 libwine mount nmap nmapfe pan procmail
    tasksel
    util-linux wine
    26 pacotes actualizados, 0 pacotes novos instalados, 0 a remover e 2 não
    actualizados.
    É necessário fazer o download de 0B/18,6MB de arquivos.
    Depois descompactar, 2754kB adicionais de espaço em disco serão utilizados.
    Você deseja continuar [Y/n]? y
    A pré-configurar os pacotes...
    E: Sub-process /usr/bin/dpkg exited unexpectedly

    Still didn't show the error! So, i did an apt-get clean again and tried
    an aptitude:

    Julinix:~# aptitude upgrade nmap
    A Ler Listas de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    A ler informações extendidas de estado
    A inicializar os estados dos pacotes... Pronto
    A ler as descrições das tarefas... Pronto
    A construir a base de dados de tags... Pronto
    Os seguintes pacotes foram mantidos:
    f-spot swf-player
    Os seguintes pacotes serão actualizados:
    apt apt-utils binutils bsdutils debconf debconf-i18n debconf-utils
    fluxbox grub iamerican ibritish ispell java-gcj-compat libglib2.0-0
    libpoppler0c2 libpoppler0c2-glib libslang2 libwine mount nmap nmapfe pan
    procmail tasksel util-linux wine
    Os seguintes pacotes estão RECOMENDADOS mas NÃO serão instalados:
    debian-archive-keyring libgcj6-src libglib2.0-data wbritish
    26 pacotes actualizados, 0 novos instalados, 0 para serem removidos e 2
    não actualizados.
    É preciso obter 16,6MB/18,6MB de ficheiros. Depois de desempacotar serão
    utilizados 2754kB.
    Deseja continuar ? [Y/n/?] y
    Obter:1 http://ftp.linux.pt unstable/main bsdutils 1:2.12r-5 [67,3kB]
    Obter:2 http://ftp.linux.pt unstable/main mount 2.12r-5 [142kB]
    Obter:3 http://ftp.linux.pt unstable/main util-linux 2.12r-5 [371kB]
    Obter:4 http://ftp.linux.pt unstable/main debconf-i18n 1.4.68 [115kB]
    Obter:5 http://ftp.linux.pt unstable/main debconf 1.4.68 [121kB]
    Obter:6 http://ftp.linux.pt unstable/main libslang2 2.0.5-3 [418kB]
    Obter:7 http://ftp.linux.pt unstable/main apt-utils 0.6.43.2 [196kB]
    Obter:8 http://ftp.linux.pt unstable/main tasksel 2.39 [156kB]
    Obter:9 http://ftp.linux.pt unstable/main binutils 2.16.1cvs20060117-1
    [2516kB]
    Obter:10 http://ftp.linux.pt unstable/main ibritish 3.1.20.0-4.1 [747kB]
    Obter:11 http://ftp.linux.pt unstable/main ispell 3.1.20.0-4.1 [154kB]
    Obter:12 http://ftp.linux.pt unstable/main iamerican 3.1.20.0-4.1 [740kB]
    Obter:13 http://ftp.linux.pt unstable/main procmail 3.22-14 [141kB]
    Obter:14 http://ftp.linux.pt unstable/main debconf-utils 1.4.68 [33,0kB]
    Obter:15 http://ftp.linux.pt unstable/main fluxbox 0.9.14-1.1 [772kB]
    Obter:16 http://ftp.linux.pt unstable/main grub 0.97-4 [364kB]
    Obter:17 http://ftp.linux.pt unstable/main java-gcj-compat 1.0.51-1 [16,3kB]
    Obter:18 http://ftp.linux.pt unstable/main libglib2.0-0 2.8.6-1 [475kB]
    Obter:19 http://ftp.linux.pt unstable/main libpoppler0c2-glib 0.4.4-2
    [40,2kB]
    Obter:20 http://ftp.linux.pt unstable/main libpoppler0c2 0.4.4-2 [445kB]
    Obter:21 http://ftp.linux.pt unstable/main wine 0.9.6-1 [390kB]
    Obter:22 http://ftp.linux.pt unstable/main libwine 0.9.6-1 [6940kB]
    Obter:23 http://ftp.linux.pt unstable/main pan 0.14.2.91-5 [1188kB]
    Obter:24 http://ftp.linux.pt unstable/main nmapfe 3.95-2 [91,8kB]
    Foi feito o download de 16,6MB em 2m39s (104kB/s)
    A pré-configurar os pacotes...
    E: Sub-process /usr/bin/dpkg exited unexpectedly
    Um pacote falhou a instalação. A tentar recuperar:
    Bus error


    I have a "Bus error" !! A friend of mine sugested that i should install
    just one package each time with dpkg after one reboot and on the first
    install:

    Julinix:/var/cache/apt/archives# dpkg -i apt_0.6.43.2_i386.deb
    Erro no barramento

    (Erro no barramento = Bus error)

    I really don't know what to do, so i'm asking help...

    Thanks in advanced and sorry for my english....


    Vjuliao

  2. Re: Apt-get >> bus error


    >
    >>
    >>I have a "Bus error" !! A friend of mine sugested that i should install
    >>just one package each time with dpkg after one reboot and on the first
    >>install:
    >>
    >>Julinix:/var/cache/apt/archives# dpkg -i apt_0.6.43.2_i386.deb
    >>Erro no barramento
    >>
    >>(Erro no barramento = Bus error)
    >>
    >>I really don't know what to do, so i'm asking help...
    >>

    >
    > Try memtest86.
    >
    >

    It's solved! The problem was file "/var/lib/dpkg/available" that was
    damaged. I just deleted the file and used available.bak to fix.

    Thanks for your sugestion, Bill

    Vjuliao

+ Reply to Thread