the hard way.. - Debian

This is a discussion on the hard way.. - Debian ; Merry Christmas to everyone! I'm writing this message just to cool down a bit. For a few days now, I installed Sarge on my computer (Dell Dimension 4550) and everything was fine. Could connect to internet and i was happy. ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: the hard way..

  1. the hard way..

    Merry Christmas to everyone!

    I'm writing this message just to cool down a bit. For a few days now,
    I installed Sarge on my computer (Dell Dimension 4550) and everything was
    fine.
    Could connect to internet and i was happy.
    Downloaded some stuff, could install it, and i was happy.
    Then, downloaded Gimp and that's the moment i started needing prozac.
    Downloaded the tar file from gimp.org but release notes recommend to get the
    deb package.
    Well..Got the deb file and did a dpkg -i, which told me I needed newer
    versions for libaal, libatk, libexif, -which needs in return needs newer
    versions libc, libatk, glibc-, libpangol.....
    And i haven't mentionned yet trying to install gtk+ which needs a newer
    version of pango, cairo,atk, freetype, fontconfig; or was it when i tried
    installing the requested latest make or pkg ?

    Anyone some words of comfort or I should just increase my pain level ?

    Thanks,

    Paul


  2. Re: the hard way..

    On Sun, 25 Dec 2005 11:34:17 +0100, polux wrote in
    alt.os.linux.debian:

    > Merry Christmas to everyone!
    >
    > I'm writing this message just to cool down a bit. For a few days now,
    > I installed Sarge on my computer (Dell Dimension 4550) and everything was
    > fine.
    > Could connect to internet and i was happy.
    > Downloaded some stuff, could install it, and i was happy.
    > Then, downloaded Gimp and that's the moment i started needing prozac.
    > Downloaded the tar file from gimp.org but release notes recommend to get the
    > deb package.
    > Well..Got the deb file and did a dpkg -i, which told me I needed newer
    > versions for libaal, libatk, libexif, -which needs in return needs newer
    > versions libc, libatk, glibc-, libpangol.....
    > And i haven't mentionned yet trying to install gtk+ which needs a newer
    > version of pango, cairo,atk, freetype, fontconfig; or was it when i tried
    > installing the requested latest make or pkg ?
    >
    > Anyone some words of comfort or I should just increase my pain level ?


    dpkg doesn't handle dependencies at all. Instead, use apt-get or
    aptitude. As root:

    # apt-get install gimp

    or

    # aptitude install gimp

    This will install the official Debian package and all its
    dependencies, including GTK.

    Alternatively, start with "apt-get install synaptic", which will give
    you a GUI package manager for installing other software. In general,
    aptitude and synaptic are the simplest options for package management.

    If, however, you need a more recent version of The GIMP than Sarge
    provides, and you don't want to use Etch or Sid, your only realistic
    options are (a) to try compiling from source or (b) to look for a
    Sarge package at backports.org. The *un*realistic option is to use
    apt-pinning (see the APT howto), which is almost certainly a bad idea
    in this case because the glibc upgrade is likely to involve too many
    other changes to the system.

    Merry Christmas!
    --
    PJR :-)

  3. Re: the hard way..

    Peter J Ross wrote:

    >
    > # apt-get install gimp
    >
    > or
    >
    > # aptitude install gimp
    >

    Peter, thanks for your quick answer, i tried doing so but then:
    *******
    apt-get install gimp
    Reading Package Lists... Done
    Building Dependency Tree... Done
    gimp is already the newest version.
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    gimp: Depends: gimp-data (= 2.2.9-7) but 2.2.6-1 is to be installed
    Depends: libaa1 (>= 1.2) but it is not installable
    libc6-dev: Depends: libc6 (= 2.3.2.ds1-22) but 2.3.5-9 is to be installed
    libpango1.0-0: Depends: libpango1.0-common (>= 1.10.1-2) but 1.8.1-1 is to
    be installed
    Depends: libcairo2 (>= 1.0.2-2) but it is not installable
    Depends: libxrender1 (> 1:0.9.0-1) but 0.8.3-7 is to be
    installed
    locales: Depends: glibc-2.3.2.ds1-22
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify
    a solution).
    **********

    I i type the latter, it says:
    *******
    0 packages upgraded, 0 newly installed, 357 to remove and 1 not upgraded.
    Need to get 0B of archives. After unpacking 815MB will be freed.
    Do you want to continue? [Y/n/?]
    ******

    Thanks anyway for helping me sorting it out!

    Paul



  4. Re: the hard way..

    polux wrote:

    Applications -> Graphics -> Gimp image editor

    I suddenly feel very tired....

    Thanks a lot Peter




  5. Re: the hard way..

    On Sun, 25 Dec 2005 13:10:53 +0100, polux wrote in
    alt.os.linux.debian:

    > Peter J Ross wrote:
    >
    >>
    >> # apt-get install gimp
    >>
    >> or
    >>
    >> # aptitude install gimp
    >>

    > Peter, thanks for your quick answer, i tried doing so but then:
    > *******
    > apt-get install gimp
    > Reading Package Lists... Done
    > Building Dependency Tree... Done
    > gimp is already the newest version.
    > You might want to run `apt-get -f install' to correct these:
    > The following packages have unmet dependencies:
    > gimp: Depends: gimp-data (= 2.2.9-7) but 2.2.6-1 is to be installed
    > Depends: libaa1 (>= 1.2) but it is not installable
    > libc6-dev: Depends: libc6 (= 2.3.2.ds1-22) but 2.3.5-9 is to be installed
    > libpango1.0-0: Depends: libpango1.0-common (>= 1.10.1-2) but 1.8.1-1 is to
    > be installed
    > Depends: libcairo2 (>= 1.0.2-2) but it is not installable
    > Depends: libxrender1 (> 1:0.9.0-1) but 0.8.3-7 is to be
    > installed
    > locales: Depends: glibc-2.3.2.ds1-22
    > E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify
    > a solution).
    > **********
    >
    > I i type the latter, it says:
    > *******
    > 0 packages upgraded, 0 newly installed, 357 to remove and 1 not upgraded.
    > Need to get 0B of archives. After unpacking 815MB will be freed.
    > Do you want to continue? [Y/n/?]
    > ******
    >
    > Thanks anyway for helping me sorting it out!


    I think this means that you installed the new version of The GIMP with
    dpkg despite the unmet dependencies. apt-get is therefore trying to
    upgrade packages to versions that are unavailable in Sarge. What
    version is reported by "gimp --version"? It should be 2.2.6, not
    2.2.9. If it's 2.2.9, try reinstalling:

    # apt-get remove gimp
    # apt-get install gimp

    Abort if you get any warnings and post the warnings.

    That's all I can suggest today; I have to go and carve some meat, and
    then drink a lot of wine. ;-)

    --
    PJR :-)

  6. Re: the hard way..

    polux wrote:
    > Peter J Ross wrote:
    >
    >
    >># apt-get install gimp
    >>
    >>or
    >>
    >># aptitude install gimp
    >>

    >
    > Peter, thanks for your quick answer, i tried doing so but then:
    > *******
    > apt-get install gimp
    > Reading Package Lists... Done
    > Building Dependency Tree... Done
    > gimp is already the newest version.
    > You might want to run `apt-get -f install' to correct these:
    > The following packages have unmet dependencies:
    > gimp: Depends: gimp-data (= 2.2.9-7) but 2.2.6-1 is to be installed
    > Depends: libaa1 (>= 1.2) but it is not installable
    > libc6-dev: Depends: libc6 (= 2.3.2.ds1-22) but 2.3.5-9 is to be installed
    > libpango1.0-0: Depends: libpango1.0-common (>= 1.10.1-2) but 1.8.1-1 is to
    > be installed
    > Depends: libcairo2 (>= 1.0.2-2) but it is not installable
    > Depends: libxrender1 (> 1:0.9.0-1) but 0.8.3-7 is to be
    > installed
    > locales: Depends: glibc-2.3.2.ds1-22
    > E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify
    > a solution).
    > **********
    >
    > I i type the latter, it says:
    > *******
    > 0 packages upgraded, 0 newly installed, 357 to remove and 1 not upgraded.
    > Need to get 0B of archives. After unpacking 815MB will be freed.
    > Do you want to continue? [Y/n/?]
    > ******
    >
    > Thanks anyway for helping me sorting it out!
    >
    > Paul
    >
    >


    Make sure your /etc/apt/sources.list contains only sarge or stable
    sources. If you try to install from etch / testing or sid / unstable,
    you will start finding dependencie problems.

    After correcting your sources.list, do an apt-get update then try
    apt-get install gimp.

  7. Re: the hard way..

    Hallo polux,

    * polux :
    > Well..Got the deb file and did a dpkg -i, which told me I needed newer


    Meeep! Don't ever do that when you can get the .deb from a working APT
    repository. In case of gimp, it is even in the official debian
    repository.

    > Anyone some words of comfort or I should just increase my pain level ?


    You should read
    .

    And you should reset your system to ”stable“

    eg do
    apt-get install `apt-show-versions | grep testing | sed -e \
    's:testing:stable'`
    and
    apt-get install `apt-show-versions | grep unstable | sed -e \
    's:unstable:stable'`
    and remove any package that apt complains isn't available in stable with
    apt-get --purge remove

    When you really want newer Applications, you can have a look at
    or upgrade to ”testing“. But be warned, in the
    latter case, your kind of on your own.

    hth, Felix

    --
    | /"\ ASCII Ribbon | Felix M. Palmen (Zirias) http://zirias.ath.cx/ |
    | \ / Campaign Against | fmp@palmen.homeip.net encrypted mail welcome |
    | X HTML In Mail | PGP key: http://zirias.ath.cx/pub.txt |
    | / \ And News | ED9B 62D0 BE39 32F9 2488 5D0C 8177 9D80 5ECF F683 |

  8. Re: the hard way..

    Thanks Felix, apt-get was an eye opener. Everything went smooth.
    Thanks again.

    Polux




    Felix M. Palmen wrote:


+ Reply to Thread