Missing /dev/dsp - using udev - Debian

This is a discussion on Missing /dev/dsp - using udev - Debian ; Hi Working with a fresh install of Debian Etch here and having some difficulty getting sound to work. I have the following modules loaded : snd_emu10k1_synth 8576 0 snd_emux_synth 40960 1 snd_emu10k1_synth snd_seq_virmidi 7424 1 snd_emux_synth snd_seq_midi_emul 7936 1 snd_emux_synth ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Missing /dev/dsp - using udev

  1. Missing /dev/dsp - using udev

    Hi

    Working with a fresh install of Debian Etch here and having some difficulty
    getting sound to work. I have the following modules loaded :


    snd_emu10k1_synth 8576 0
    snd_emux_synth 40960 1 snd_emu10k1_synth
    snd_seq_virmidi 7424 1 snd_emux_synth
    snd_seq_midi_emul 7936 1 snd_emux_synth
    snd_seq_dummy 3844 0
    snd_seq_oss 36224 0
    snd_seq_midi 10528 0
    snd_seq_midi_event 7168 3 snd_seq_virmidi,snd_seq_oss,snd_seq_midi
    snd_seq 57744 9
    snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,s nd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi _event
    snd_emu10k1 130084 1 snd_emu10k1_synth
    snd_rawmidi 26400 3 snd_seq_virmidi,snd_seq_midi,snd_emu10k1
    snd_seq_device 9100 8
    snd_emu10k1_synth,snd_emux_synth,snd_seq_dummy,snd _seq_oss,snd_seq_midi,snd_seq,snd_emu10k1,snd_rawm idi
    snd_ac97_codec 100348 1 snd_emu10k1
    snd_pcm_oss 63904 0
    snd_mixer_oss 21632 1 snd_pcm_oss
    snd_pcm 102024 3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
    snd_timer 26500 3 snd_seq,snd_emu10k1,snd_pcm
    snd_ac97_bus 2432 1 snd_ac97_codec
    snd_page_alloc 11784 2 snd_emu10k1,snd_pcm
    snd_util_mem 5120 2 snd_emux_synth,snd_emu10k1
    snd_hwdep 9632 2 snd_emux_synth,snd_emu10k1
    snd 60004 13
    snd_emux_synth,snd_seq_virmidi,snd_seq_oss,snd_seq ,snd_emu10k1,snd_rawmidi,snd_seq_device,snd_ac97_c odec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,s nd_hwdep
    soundcore 10080 1 snd

    I get an error message :

    Sound server informational message:
    Error while initializing the sound driver:
    device /dev/dsp can't be opened (No such file or directory)
    The sound server will continue, using the null output device.

    Indeed, there is no /dev/dsp with this custom compiled kernel (2.6.14.3 with
    the software suspend 2 patch). How do I make sure it gets set up
    correctly ? And, any good references for working with udev ?

    Thanks.

  2. Re: Missing /dev/dsp - using udev

    "Madhusudan Singh" wrote in message
    news:dn5p9v$na0$1@domitilla.aioe.org

    > I get an error message :
    >
    > Sound server informational message:
    > Error while initializing the sound driver:
    > device /dev/dsp can't be opened (No such file or directory)
    > The sound server will continue, using the null output device.
    >
    > Indeed, there is no /dev/dsp with this custom compiled kernel
    > (2.6.14.3 with the software suspend 2 patch). How do I make
    > sure it gets set up correctly ?


    # cd /dev; ./MAKEDEV -v sound

    "man MAKEDEV" for further info.

  3. Re: Missing /dev/dsp - using udev

    ynotssor wrote:

    > "Madhusudan Singh" wrote in message
    > news:dn5p9v$na0$1@domitilla.aioe.org
    >
    >> I get an error message :
    >>
    >> Sound server informational message:
    >> Error while initializing the sound driver:
    >> device /dev/dsp can't be opened (No such file or directory)
    >> The sound server will continue, using the null output device.
    >>
    >> Indeed, there is no /dev/dsp with this custom compiled kernel
    >> (2.6.14.3 with the software suspend 2 patch). How do I make
    >> sure it gets set up correctly ?

    >
    > # cd /dev; ./MAKEDEV -v sound
    >
    > "man MAKEDEV" for further info.


    nanak:/dev# ./MAKEDEV -v sound
    create mixer c 14 0 root:audio 0660
    create mixer1 c 14 16 root:audio 0660
    create mixer2 c 14 32 root:audio 0660
    create mixer3 c 14 48 root:audio 0660
    create sequencer c 14 1 root:audio 0660
    create midi00 c 14 2 root:audio 0660
    create midi01 c 14 18 root:audio 0660
    create midi02 c 14 34 root:audio 0660
    create midi03 c 14 50 root:audio 0660
    create dsp c 14 3 root:audio 0660
    create dsp1 c 14 19 root:audio 0660
    create dsp2 c 14 35 root:audio 0660
    create dsp3 c 14 51 root:audio 0660
    create audio c 14 4 root:audio 0660
    create audio1 c 14 20 root:audio 0660
    create audio2 c 14 36 root:audio 0660
    create audio3 c 14 52 root:audio 0660
    create sndstat c 14 6 root:audio 0660
    create audioctl c 14 7 root:audio 0660
    create mpu401data c 31 0 root:audio 0660
    create mpu401stat c 31 1 root:audio 0660
    create midi0 c 35 0 root:audio 0660
    create rmidi0 c 35 64 root:audio 0660
    create smpte0 c 35 128 root:audio 0660
    create midi1 c 35 1 root:audio 0660
    create rmidi1 c 35 65 root:audio 0660
    create smpte1 c 35 129 root:audio 0660
    create midi2 c 35 2 root:audio 0660
    create rmidi2 c 35 66 root:audio 0660
    create smpte2 c 35 130 root:audio 0660
    create midi3 c 35 3 root:audio 0660
    create rmidi3 c 35 67 root:audio 0660
    create smpte3 c 35 131 root:audio 0660

    Didn't work for me. However, it has created a bunch of dsp devices (among
    other things) under /dev/.static/dev/ :

    nanak:/dev/.static/dev# ls -ltr dsp*
    crw-rw---- 1 root audio 14, 3 2005-12-05 22:51 dsp0
    crw-rw---- 1 root audio 14, 51 2005-12-07 10:20 dsp3
    crw-rw---- 1 root audio 14, 35 2005-12-07 10:20 dsp2
    crw-rw---- 1 root audio 14, 19 2005-12-07 10:20 dsp1
    crw-rw---- 1 root audio 14, 3 2005-12-07 10:20 dsp

    I have never seen this kind of thing before. What is going on ?

+ Reply to Thread