Package dependencies problems - BSD

This is a discussion on Package dependencies problems - BSD ; Hello, I have depencies problems with two packages with OpenBSD 3.9 I386. When I run: export PKG_PATH=ftp://ftp.usa.openbsd.org/pub/OpenBSD/3.9/packages/i386/ pkg_add -v mldonkey-2.6.3p1.tgz parsing mldonkey-2.6.3p1 Dependencies for mldonkey-2.6.3p1 resolve to: gtk+-1.2.10p4, gd-2.0.33p2, bzip2-1.0.3 (todo: gd-2.0.33p2,gtk+-1.2.10p4) mldonkey-2.6.3p1 arsing gd-2.0.33p2 Dependencies for gd-2.0.33p2 resolve to: ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: Package dependencies problems

  1. Package dependencies problems

    Hello,

    I have depencies problems with two packages with OpenBSD 3.9 I386.

    When I run:
    export PKG_PATH=ftp://ftp.usa.openbsd.org/pub/OpenBSD/3.9/packages/i386/
    pkg_add -v mldonkey-2.6.3p1.tgz

    parsing mldonkey-2.6.3p1
    Dependencies for mldonkey-2.6.3p1 resolve to: gtk+-1.2.10p4, gd-2.0.33p2,
    bzip2-1.0.3 (todo: gd-2.0.33p2,gtk+-1.2.10p4)
    mldonkey-2.6.3p1arsing gd-2.0.33p2
    Dependencies for gd-2.0.33p2 resolve to: jpeg-6bp3, png-1.2.8,
    libiconv-1.9.2p3
    Can't install gd-2.0.33p2: lib not found fontconfig.3.0
    Even by looking in the dependency tree:
    jpeg-6bp3, png-1.2.8, libiconv-1.9.2p3
    Maybe it's in a dependent package, but not tagged with @lib ?
    (check with pkg_info -K -L)
    If you are still running 3.6 packages, update them.
    Can't install gd-2.0.33p2: lib not found freetype.13.1
    mldonkey-2.6.3p1arsing gtk+-1.2.10p4
    Dependencies for gtk+-1.2.10p4 resolve to: gettext-0.14.5p1, glib-1.2.10p1,
    libiconv-1.9.2p3
    Can't install gtk+-1.2.10p4: lib not found X11.9.0
    Even by looking in the dependency tree:
    gettext-0.14.5p1, expat-1.95.6p1, glib-1.2.10p1, libiconv-1.9.2p3
    Maybe it's in a dependent package, but not tagged with @lib ?
    (check with pkg_info -K -L)
    If you are still running 3.6 packages, update them.
    Can't install gtk+-1.2.10p4: lib not found Xext.9.0
    Can't install gtk+-1.2.10p4: lib not found Xi.9.0
    Can't install mldonkey-2.6.3p1.tgz: can't resolve gtk+-1.2.10p4
    #

    ****************
    And another package:

    pkg_add -v php5-imap-5.0.5p1.tgz


    # pkg_add -v php5-imap-5.0.5p1.tgz
    parsing php5-imap-5.0.5p1
    Dependencies for php5-imap-5.0.5p1 resolve to: c-client-4.61p0,
    php5-core-5.0.5
    Can't install php5-imap-5.0.5p1.tgz: lib not found gssapi.4.0
    Even by looking in the dependency tree:
    gettext-0.14.5p1, c-client-4.61p0, expat-1.95.6p1, libxml-2.6.16p8,
    libiconv-1.9.2p3, php5-core-5.0.5
    Maybe it's in a dependent package, but not tagged with @lib ?
    (check with pkg_info -K -L)
    If you are still running 3.6 packages, update them.
    Can't install php5-imap-5.0.5p1.tgz: lib not found krb5.15.0
    Error from http://ftp.jyu.fi/ftp/pub/OpenBSD/3.9/packages/i386/:
    ftp: Writing -: Broken pipe


    *************
    Can somebody help me to fix these problems?

    Thank you very much in advance...



  2. Re: Package dependencies problems

    OBSD (spulletjes7500@hotmail.com) wrote:

    > I have depencies problems with two packages with OpenBSD 3.9 I386.
    >
    > When I run:
    > export PKG_PATH=ftp://ftp.usa.openbsd.org/pub/OpenBSD/3.9/packages/i386/
    > pkg_add -v mldonkey-2.6.3p1.tgz
    >
    > parsing mldonkey-2.6.3p1
    > Dependencies for mldonkey-2.6.3p1 resolve to: gtk+-1.2.10p4, gd-2.0.33p2,
    > bzip2-1.0.3 (todo: gd-2.0.33p2,gtk+-1.2.10p4)
    > mldonkey-2.6.3p1arsing gd-2.0.33p2
    > Dependencies for gd-2.0.33p2 resolve to: jpeg-6bp3, png-1.2.8,
    > libiconv-1.9.2p3
    > Can't install gd-2.0.33p2: lib not found fontconfig.3.0


    You do not have installed xbase.

    Personally I think it is very very very sad that someone needs xbase to use
    e.g. webalizer. Very very very sad, especially for OpenBSD.

    --
    Please do not feed my mailbox, Swen still does his job well


  3. Re: Package dependencies problems

    Hello Helmut,

    The MLdonkey was fixed by installing xbase.
    Thank you very much for your answer!

    However the php5 imap package can not be installed.
    And this one is more important for me

    [root@nagasaki:/] # pkg_add -v php5-imap-5.0.5p1.tgz
    parsing php5-imap-5.0.5p1
    Dependencies for php5-imap-5.0.5p1 resolve to: c-client-4.61p0,
    php5-core-5.0.5
    Can't install php5-imap-5.0.5p1.tgz: lib not found gssapi.4.0
    Even by looking in the dependency tree:
    gettext-0.14.5p1, c-client-4.61p0, expat-1.95.6p1, libxml-2.6.16p8,
    libiconv-1.9.2p3, php5-core-5.0.5
    Maybe it's in a dependent package, but not tagged with @lib ?
    (check with pkg_info -K -L)
    If you are still running 3.6 packages, update them.
    Can't install php5-imap-5.0.5p1.tgz: lib not found krb5.15.0

    ****
    Somebody an answer for this one?

    Thank you in advance...

    *************
    "Helmut Schneider" schreef in bericht
    news:4dj1cqF1af52sU1@individual.net...
    > OBSD (spulletjes7500@hotmail.com) wrote:
    >
    >> I have depencies problems with two packages with OpenBSD 3.9 I386.
    >>
    >> When I run:
    >> export PKG_PATH=ftp://ftp.usa.openbsd.org/pub/OpenBSD/3.9/packages/i386/
    >> pkg_add -v mldonkey-2.6.3p1.tgz
    >>
    >> parsing mldonkey-2.6.3p1
    >> Dependencies for mldonkey-2.6.3p1 resolve to: gtk+-1.2.10p4, gd-2.0.33p2,
    >> bzip2-1.0.3 (todo: gd-2.0.33p2,gtk+-1.2.10p4)
    >> mldonkey-2.6.3p1arsing gd-2.0.33p2
    >> Dependencies for gd-2.0.33p2 resolve to: jpeg-6bp3, png-1.2.8,
    >> libiconv-1.9.2p3
    >> Can't install gd-2.0.33p2: lib not found fontconfig.3.0

    >
    > You do not have installed xbase.
    >
    > Personally I think it is very very very sad that someone needs xbase to
    > use e.g. webalizer. Very very very sad, especially for OpenBSD.
    >
    > --
    > Please do not feed my mailbox, Swen still does his job well




  4. Re: Package dependencies problems

    Helmut Schneider wrote:
    >> Can't install gd-2.0.33p2: lib not found fontconfig.3.0

    >
    > You do not have installed xbase.
    >
    > Personally I think it is very very very sad that someone needs xbase to use
    > e.g. webalizer. Very very very sad, especially for OpenBSD.
    >

    Jacal also will not install on a non-X system
    because of a dependency upon an X library.
    --
    Using ( X | KDE ) with OpenBSD?
    See Dave's OpenBSD | X | KDE corner at
    http://dfeustel.home.mindspring.com !!!

  5. Re: Package dependencies problems

    dfeustel@mindspring.com a écrit :
    > Helmut Schneider wrote:
    >
    >>>Can't install gd-2.0.33p2: lib not found fontconfig.3.0

    >>
    >>You do not have installed xbase.
    >>
    >>Personally I think it is very very very sad that someone needs xbase to use
    >>e.g. webalizer. Very very very sad, especially for OpenBSD.
    >>

    >
    > Jacal also will not install on a non-X system
    > because of a dependency upon an X library.

    I have the same problem installing pfstat wich needing gd2...
    I finally extract the two library (libfontconfig and libfreetype) from
    xbase.tgz and place them in /usr/X11R6/lib.
    I hope this will be fixed in future release.

    --
    raf

  6. Re: Package dependencies problems

    OBSD wrote:

    > The MLdonkey was fixed by installing xbase.
    > Thank you very much for your answer!
    > However the php5 imap package can not be installed.
    > And this one is more important for me
    > [root@nagasaki:/] # pkg_add -v php5-imap-5.0.5p1.tgz
    > parsing php5-imap-5.0.5p1
    > Dependencies for php5-imap-5.0.5p1 resolve to: c-client-4.61p0,
    > php5-core-5.0.5
    > Can't install php5-imap-5.0.5p1.tgz: lib not found gssapi.4.0


    Does "/usr/lib/libgssapi.so.4.0" exist? If yes you should try to compile the
    package yourself from /usr/ports/www/php5


+ Reply to Thread