HPLIP OpenBSD 3.8 - BSD

This is a discussion on HPLIP OpenBSD 3.8 - BSD ; Hi all I have to run print server with OpenBSD 3.8+ samba+CUPS. CUPS+samba no problem but when I like to compile hplip tar.gz I get this message: checking for usb_init in -lusb... no configure: error: cannot find libusb support I ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: HPLIP OpenBSD 3.8

  1. HPLIP OpenBSD 3.8

    Hi all
    I have to run print server with OpenBSD 3.8+ samba+CUPS.
    CUPS+samba no problem but when I like to compile hplip tar.gz I get this
    message:
    checking for usb_init in -lusb... no
    configure: error: cannot find libusb support
    I installed libusb-0.1.10a but I get same problem.

    USB no work??

    Thank you for your help



  2. Re: HPLIP OpenBSD 3.8

    calico wrote:
    > Hi all
    > I have to run print server with OpenBSD 3.8+ samba+CUPS.
    > CUPS+samba no problem but when I like to compile hplip tar.gz I get this
    > message:
    > checking for usb_init in -lusb... no
    > configure: error: cannot find libusb support
    > I installed libusb-0.1.10a but I get same problem.
    >
    > USB no work??


    Considering the fact that the website cites libusb 10.1.8+ as a
    requirement, this is hardly surprising. It also explicitly lists a Linux
    kernel, though this need not mean anything.

    I have no idea how to get this working; another CUPS backend might
    serve your needs better.

    Joachim

  3. Re: HPLIP OpenBSD 3.8

    HP hates *BSD....... just kidding.....

    The problem is all my printers are HP and I don't like to run a Linux
    server. Hplip.tar.gz looks fine but I can't compile.....

    I will search other way.....

    Thank you very much.

    Cal.






    escribió en el mensaje
    news:443bbf26$0$34180$dbd49001@news.wanadoo.nl...
    > calico wrote:
    >> Hi all
    >> I have to run print server with OpenBSD 3.8+ samba+CUPS.
    >> CUPS+samba no problem but when I like to compile hplip tar.gz I get this
    >> message:
    >> checking for usb_init in -lusb... no
    >> configure: error: cannot find libusb support
    >> I installed libusb-0.1.10a but I get same problem.
    >>
    >> USB no work??

    >
    > Considering the fact that the website cites libusb 10.1.8+ as a
    > requirement, this is hardly surprising. It also explicitly lists a Linux
    > kernel, though this need not mean anything.
    >
    > I have no idea how to get this working; another CUPS backend might
    > serve your needs better.
    >
    > Joachim




  4. Re: HPLIP OpenBSD 3.8

    calico wrote:
    > HP hates *BSD....... just kidding.....
    >
    > The problem is all my printers are HP and I don't like to run a Linux
    > server. Hplip.tar.gz looks fine but I can't compile.....
    >
    > I will search other way.....


    If there is no stock solution for CUPS, I'd suggest trying to done down
    the compilation as much as possible.

    That being said, the thing you want to compile is large, with a lot of
    dependencies and a lot of bells - the actual driver is much smaller. It
    might be possible to isolate this.

    However, from a look at the site, I'd much prefer a proper configuration
    for CUPS to the completely redone printing system HP offers.

    Joachim

+ Reply to Thread