OpenSSH freeze problem - BSD

This is a discussion on OpenSSH freeze problem - BSD ; I'm having a very persistent problem with SSH access to a client's OBSD 3.6 server. SSH connects fine but if there is no activity for about 20 seconds then the link freezes and will do nothing until the links time ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: OpenSSH freeze problem

  1. OpenSSH freeze problem

    I'm having a very persistent problem with SSH access to a client's OBSD 3.6
    server. SSH connects fine but if there is no activity for about 20 seconds
    then the link freezes and will do nothing until the links time out (about
    25 minutes).

    I've tried changing ClientAlive internal (10) and ClientAliveCountMax with
    no effect.

    I've also tried dropping the MTU in both directions (although for the life
    of me I cannot understand how that might cause this problem).

    Neither this group or the OpenSSH mailing list seem to record anything
    similar.

    Netstat -a shows packets waiting to go at the client end but none at the
    server end.

    Server is a standard installation. Clients have been Slackware 9.1 and OBSD
    3.6. Both ends are on DSL and diferent ISP's are involved although another
    server with the same remote ISP but different location has no problems at
    all.

    Anyone got any clues ?

  2. Re: OpenSSH freeze problem

    "Keith Matthews" wrote in message
    news:xeidndQOzaR4D2HfRVnyrw@eclipse.net.uk...
    > I'm having a very persistent problem with SSH access to a client's OBSD
    > 3.6
    > server. SSH connects fine but if there is no activity for about 20 seconds
    > then the link freezes and will do nothing until the links time out (about
    > 25 minutes).




    The only time I came across anything like that was when there was a
    corporate firewall in the way that was blocking certain ports (which turned
    out to include SSH). Otherwise, I suspect a general networking issue - have
    you proved that everything other than SSH works?

    You say it connects ok - are any of the high ports blocked anywhere along
    the line?

    Steve
    http://www.fivetrees.com



  3. Re: OpenSSH freeze problem

    Steve at fivetrees wrote:

    > "Keith Matthews" wrote in message
    > news:xeidndQOzaR4D2HfRVnyrw@eclipse.net.uk...
    >> I'm having a very persistent problem with SSH access to a client's OBSD
    >> 3.6
    >> server. SSH connects fine but if there is no activity for about 20
    >> seconds then the link freezes and will do nothing until the links time
    >> out (about 25 minutes).

    >
    >
    >
    > The only time I came across anything like that was when there was a
    > corporate firewall in the way that was blocking certain ports (which
    > turned out to include SSH).


    Effectively this machine is the corporate firewall, my end too. Only thing
    under user control at each end is the DSL router.

    > Otherwise, I suspect a general networking
    > issue - have you proved that everything other than SSH works?
    >


    No complaints of anything else having problems.

    Comprehensive testing is hardly practical and there's only 2 users at the
    far end.

    > You say it connects ok - are any of the high ports blocked anywhere along
    > the line?
    >


    If so it's done by and ISP somewhere, and both advertise that they don't
    block ports.

    I'll check it again as soon as I have a chance.

+ Reply to Thread