dell memory oddities - BSD

This is a discussion on dell memory oddities - BSD ; I have a Dell 400SC and another SC420, both running OBSD (3.5 and 3.6, respectively). I just topped them both up to a full 4GB of memory. The odd thing is that the SC420, running 3.6, doesn't see all the ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: dell memory oddities

  1. dell memory oddities

    I have a Dell 400SC and another SC420, both running OBSD (3.5 and 3.6,
    respectively). I just topped them both up to a full 4GB of memory.

    The odd thing is that the SC420, running 3.6, doesn't see all the memory: dmesg says

    real mem = 3613552640 (3528860K)
    avail mem = 3290484736 (3213364K)

    The 400SC, running 3.5, has its own little problem with this, but appears to see
    all the bits:

    real mem = 4025548800 (4294704192K)
    avail mem = 3730812928 (3643372K)

    Is this a known problem? Anyone have a patch? The BIOS sees all the memory in
    both cases.

    Thanks,
    chris

  2. Re: dell memory oddities

    >I have a Dell 400SC and another SC420, both running OBSD (3.5 and 3.6,
    >respectively). I just topped them both up to a full 4GB of memory.
    >
    > The odd thing is that the SC420, running 3.6, doesn't see all the memory:
    > dmesg says
    >
    > real mem = 3613552640 (3528860K)
    > avail mem = 3290484736 (3213364K)
    >
    > The 400SC, running 3.5, has its own little problem with this, but appears
    > to see all the bits:
    >
    > real mem = 4025548800 (4294704192K)
    > avail mem = 3730812928 (3643372K)


    Try the latest bios firmware, maybe they differ.
    http://support.dell.com/support/down...3841&devlib=13

    Otherwise read `man 8 boot.conf` and look for `machine mem` section.
    I'm running a couple obsd 3.7 servers with 4gigs of mem without any
    problems,
    i did had this issue once with an old compaq proliant server once.
    Instead of 265mb it only noticed 64mb or so.


    -Bas



  3. Re: dell memory oddities

    Bas Keur wrote:
    >>I have a Dell 400SC and another SC420, both running OBSD (3.5 and 3.6,
    >>respectively). I just topped them both up to a full 4GB of memory.
    >>
    >>The odd thing is that the SC420, running 3.6, doesn't see all the memory:
    >>dmesg says
    >>
    >>real mem = 3613552640 (3528860K)
    >>avail mem = 3290484736 (3213364K)
    >>
    >>The 400SC, running 3.5, has its own little problem with this, but appears
    >>to see all the bits:
    >>
    >>real mem = 4025548800 (4294704192K)
    >>avail mem = 3730812928 (3643372K)

    >
    >


    It seems that the SC420 architecture steals a bunch of RAM for onboard video and
    some PCI registers, so this is "normal" ... if annoying.

+ Reply to Thread