I have some issues with X after upgrading from 3.6 to 3.7

3.7 is running on a i386, Sony Vaio r505 TEK with a i810 or vga1 at
pci0 dev 2 function 0 "Intel 82815 Graphics" rev 0x11: aperture at
0xf8000000, size 0x4000000

/var/log/Xorg.0.log shows:

(--) checkDevMem: using aperture driver /dev/xf86
(--) Using wscons driver in pcvt compatibility mode (version 3.32)

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: OpenBSD 3.7 i386 [ELF]
Current Operating System: OpenBSD luna.xxxx.xxx 3.7 GENERIC#50 i386
Build Date: 16 March 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon May 23 19:16:55 2005
(==) Using config file: "/etc/X11/xorg.conf"
....
[26] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
[27] 0 0 0x000003c0 - 0x000003df (0x20) IS[B](OprU)
(WW) I810(0): xf86AcquireGART: AGPIOC_ACQUIRE failed (Inappropriate
ioctl for device)
(EE) I810(0): AGP GART support is either not available or cannot be
used.
Make sure your kernel has agpgart support or has the
agpgart module loaded.

I had some issues with xf86AcquireGART with 3.6, but a restart solved
the problem. However, I never had any issue with AGP GART before. Any
pointers are appreciated.