Mozilla apps and nss - BSD

This is a discussion on Mozilla apps and nss - BSD ; Hello. I am having trouble upgrading Mozilla apps like Firefox and xulrunner on a system running 5.4-release. These apps depend on nss-3.11.5, so attempt to install it first. The installation of nss appears to proceed successfully, but when the install ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Mozilla apps and nss

  1. Mozilla apps and nss

    Hello. I am having trouble upgrading Mozilla apps like Firefox and
    xulrunner on a system running 5.4-release. These apps depend on
    nss-3.11.5, so attempt to install it first. The installation of nss
    appears to proceed successfully, but when the install returns to
    building the Mozilla app, it craps out with the error msg 'shared
    library "nss3" does not exist'; e.g., attempting to install yelp with
    xulrunner resulted in the following:

    install -o root -g wheel -m 555 /usr/ports/security/nss/work/nss-config \
    /usr/local/bin
    install -o root -g wheel -m 444 /usr/ports/security/nss/work/nss.pc \
    /usr/local/libdata/pkgconfig
    ===> Running ldconfig
    /sbin/ldconfig -m /usr/local/lib/nss
    ldconfig: /usr/local/lib/nss: ignoring group-writable directory
    ===> Installing ldconfig configuration file
    ===> Registering installation for nss-3.11.5
    ===> Returning to build of xulrunner-1.8.0.4_6
    Error: shared library "nss3" does not exist
    *** Error code 1

    Stop in /usr/ports/www/xulrunner.
    *** Error code 1

    Stop in /usr/ports/www/xulrunner.
    *** Error code 1

    Stop in /usr/ports/x11/yelp.

    Suggestions much appreciated.

    Chris Menzel


  2. Re: Mozilla apps and nss

    In article Chris Menzel
    writes:
    >Hello. I am having trouble upgrading Mozilla apps like Firefox and
    >xulrunner on a system running 5.4-release. These apps depend on
    >nss-3.11.5, so attempt to install it first. The installation of nss
    >appears to proceed successfully, but when the install returns to
    >building the Mozilla app, it craps out with the error msg 'shared
    >library "nss3" does not exist'; e.g., attempting to install yelp with
    >xulrunner resulted in the following:
    >
    >install -o root -g wheel -m 555 /usr/ports/security/nss/work/nss-config \
    >/usr/local/bin
    >install -o root -g wheel -m 444 /usr/ports/security/nss/work/nss.pc \
    >/usr/local/libdata/pkgconfig
    >===> Running ldconfig
    >/sbin/ldconfig -m /usr/local/lib/nss
    >ldconfig: /usr/local/lib/nss: ignoring group-writable directory

    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^
    >===> Installing ldconfig configuration file
    >===> Registering installation for nss-3.11.5
    >===> Returning to build of xulrunner-1.8.0.4_6
    >Error: shared library "nss3" does not exist


    >Suggestions much appreciated.


    Look at the error message above, and fix the problem (see the ldconfig
    man page - but using '-i' is not the right fix...).

    --Per Hedeland
    per@hedeland.org

  3. Re: Mozilla apps and nss

    On Tue, 27 Mar 2007 23:54:47 +0000 (UTC), Per Hedeland
    said:
    > In article Chris Menzel
    > writes:
    >>Hello. I am having trouble upgrading Mozilla apps like Firefox and
    >>xulrunner on a system running 5.4-release. These apps depend on
    >>nss-3.11.5, so attempt to install it first. The installation of nss
    >>appears to proceed successfully, but when the install returns to
    >>building the Mozilla app, it craps out with the error msg 'shared
    >>library "nss3" does not exist'; e.g., attempting to install yelp with
    >>xulrunner resulted in the following:
    >>
    >>install -o root -g wheel -m 555 /usr/ports/security/nss/work/nss-config \
    >>/usr/local/bin
    >>install -o root -g wheel -m 444 /usr/ports/security/nss/work/nss.pc \
    >>/usr/local/libdata/pkgconfig
    >>===> Running ldconfig
    >>/sbin/ldconfig -m /usr/local/lib/nss
    >>ldconfig: /usr/local/lib/nss: ignoring group-writable directory

    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^
    >>===> Installing ldconfig configuration file
    >>===> Registering installation for nss-3.11.5
    >>===> Returning to build of xulrunner-1.8.0.4_6
    >>Error: shared library "nss3" does not exist

    >
    >>Suggestions much appreciated.

    >
    > Look at the error message above, and fix the problem (see the ldconfig
    > man page - but using '-i' is not the right fix...).


    Well, that was such a gentle and unobtrusive little message that I
    didn't even think of it as expressing an *error*. :-) Thanks,
    clobbering group write permissions on that dir did the trick.

    Chris Menzel


  4. Re: Mozilla apps and nss

    In article Chris Menzel
    writes:
    >On Tue, 27 Mar 2007 23:54:47 +0000 (UTC), Per Hedeland
    > said:
    >> In article Chris Menzel
    >> writes:
    >>>ldconfig: /usr/local/lib/nss: ignoring group-writable directory

    > ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ ^^^^^^^^^^^^^
    >>>===> Installing ldconfig configuration file
    >>>===> Registering installation for nss-3.11.5
    >>>===> Returning to build of xulrunner-1.8.0.4_6
    >>>Error: shared library "nss3" does not exist

    >>
    >>>Suggestions much appreciated.

    >>
    >> Look at the error message above, and fix the problem (see the ldconfig
    >> man page - but using '-i' is not the right fix...).

    >
    >Well, that was such a gentle and unobtrusive little message that I
    >didn't even think of it as expressing an *error*. :-)


    Yeah, I guess strictly speaking it's a "warning" message, since ldconfig
    continues and finally exits with code 0 - otherwise you would have
    gotten a nice make bomb-out at *that* point. At least it was near the
    end of the output.:-)

    --Per Hedeland
    per@hedeland.org

+ Reply to Thread