Xorg exiting problem on FBSD 6.2 - BSD

This is a discussion on Xorg exiting problem on FBSD 6.2 - BSD ; Hi, After upgrading from 6.1 to 6.2, I started having problems exiting X. Symptoms are mostly that either the screen gets and stays black or gives weird colours all over. Problem is also that the other terminal screens can't be ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Xorg exiting problem on FBSD 6.2

  1. Xorg exiting problem on FBSD 6.2

    Hi,

    After upgrading from 6.1 to 6.2, I started having problems exiting X.
    Symptoms are mostly that either the screen gets and stays black or gives
    weird colours all over. Problem is also that the other terminal screens
    can't be reached anymore. The wm doesn't matter: fluxbox, xfce, gnome
    all work well. Also, when I ssh to the machine and kill the X-server, it
    doesn't help. All that I seemingly can do is reboot from ssh.
    Now I have reinstalled the machine, and find that the problem comes
    after I configure X. After "pkg_add -r xorg", I can start and exit X ok.
    As soon as I have done "Xorg -configure", start "X -conf
    /root/xorg.conf.new" and try to exit it goes wrong again. Xorg.0.log
    only says "failed" in the end, but I think that's because of the
    ctrl-alt-backspace after running the test.

    My hw: PentiumIII 500MHz, 256 MB RAM, Savage4 pci video.

    Any idea anyone?

    Thanks,

    Huub

  2. Re: Xorg exiting problem on FBSD 6.2

    Begin <45e2c81f$0$3860$e4fe514c@dreader27.news.xs4all.nl>
    On 2007-02-26, Huub <"v.niekerk at hccnet.nl"> wrote:
    > After upgrading from 6.1 to 6.2, I started having problems exiting X.
    > Symptoms are mostly that either the screen gets and stays black or gives
    > weird colours all over. Problem is also that the other terminal screens
    > can't be reached anymore.

    [snip!]
    > My hw: PentiumIII 500MHz, 256 MB RAM, Savage4 pci video.
    >
    > Any idea anyone?


    Sounds like something wrong with the hardware driver, or perhaps the
    hardware.

    The first thing you can try is changing the driver to generic VESA. It
    won't be fast but it might work, and it might help isolate the problem.

    After that, you might try and ask people who know things about Xorg and
    graphics hardware drivers, or search around for savage4 problems.


    --
    j p d (at) d s b (dot) t u d e l f t (dot) n l .
    This message was originally posted on Usenet in plain text.
    Any other representation, additions, or changes do not have my
    consent and may be a violation of international copyright law.

  3. Re: Xorg exiting problem on FBSD 6.2

    >
    > Sounds like something wrong with the hardware driver, or perhaps the
    > hardware.
    >
    > The first thing you can try is changing the driver to generic VESA. It
    > won't be fast but it might work, and it might help isolate the problem.
    >
    > After that, you might try and ask people who know things about Xorg and
    > graphics hardware drivers, or search around for savage4 problems.
    >
    >


    Thank you.

  4. Re: Xorg exiting problem on FBSD 6.2

    Huub schrieb:
    >>
    >> Sounds like something wrong with the hardware driver, or perhaps the
    >> hardware.
    >>
    >> The first thing you can try is changing the driver to generic VESA. It
    >> won't be fast but it might work, and it might help isolate the problem.
    >>
    >> After that, you might try and ask people who know things about Xorg and
    >> graphics hardware drivers, or search around for savage4 problems.
    >>
    >>

    >
    > Thank you.

    you could do a "dmesg" or "tail -f /var/log/message" and have a look at
    the output. Perhaps you could gather some information on failed module
    loads and uninitialized hardware, then ask again.

    kind regards,

    Michael

+ Reply to Thread