Hi folks,

I am attempting to install win2k via qemu-launcher:

Formating '/home4/win2k', fmt=raw, size=15728640 kB

/usr/local/bin/qemu-system-x86_64 -boot d -m 512 -hda '/home4/win2k'
-cdrom '/dev/acd0' -net nic,vlan=0 -net user,vlan=0 -localtime

This cores during the "Setup is starting Windows 2000"
phase. Using qcow, it crashes MUCH sooner - it doesn't go
through the setup screen before crashing. Using straight
'qemu" does not help.

Truss reports the failure happens on an "aio_read":

sigprocmask(SIG_BLOCK,0x0,0x0) = 0 (0x0)
sigprocmask(SIG_SETMASK,0x0,0x0) = 0 (0x0)
SIGNAL 14 (SIGALRM)
SIGNAL 14 (SIGALRM)
sigprocmask(SIG_BLOCK,0x0,SIGHUP|SIGINT|SIGQUIT|SI GILL|SIGTRAP|SIGABRT|SIGEMT|SIGFPE|SIGBUS|SIGSEGV| SIGSYS|SIGPIPE|SIGALRM|SIGTERM|SIGURG|SIGTSTP|SIGC ONT|SIGCHLD|SIGTTIN|SIGTTOU|SIGIO|SIGXCPU|SIGXFSZ| SIGVTALRM|SIGPROF|SIGWINCH|SIGINFO|SIGUSR1|SIGUSR2 ) = 0 (0x0)
clock_gettime(4,{372502.439549775}) = 0 (0x0)
sigreturn(0x7fffffffac70) = 0 (0x0)
nanosleep({0.000000000}) = 0 (0x0)
gettimeofday({1170387255.970558},0x0) = 0 (0x0)
clock_gettime(4,{372502.439860150}) = 0 (0x0)
clock_gettime(4,{372502.439936696}) = 0 (0x0)
sigprocmask(SIG_BLOCK,0x0,0x0) = 0 (0x0)
sigprocmask(SIG_SETMASK,0x0,0x0) = 0 (0x0)
sigprocmask(SIG_SETMASK,0x0,0x0) = 0 (0x0)
sigprocmask(SIG_SETMASK,0x0,0x0) = 0 (0x0)
SIGNAL 14 (SIGALRM)
SIGNAL 14 (SIGALRM)
sigprocmask(SIG_BLOCK,0x0,SIGHUP|SIGINT|SIGQUIT|SI GILL|SIGTRAP|SIGABRT|SIGEMT|SIGFPE|SIGBUS|SIGSEGV| SIGSYS|SIGPIPE|SIGALRM|SIGTERM|SIGURG|SIGTSTP|SIGC ONT|SIGCHLD|SIGTTIN|SIGTTOU|SIGIO|SIGXCPU|SIGXFSZ| SIGVTALRM|SIGPROF|SIGWINCH|SIGINFO|SIGUSR1|SIGUSR2 ) = 0 (0x0)
clock_gettime(4,{372502.440467210}) = 0 (0x0)
clock_gettime(4,{372502.440535655}) = 0 (0x0)
sigreturn(0x7fffffffac60) = 0 (0x0)
sigprocmask(SIG_BLOCK,0x0,0x0) = 0 (0x0)
sigprocmask(SIG_SETMASK,0x0,0x0) = 0 (0x0)
nanosleep({0.000000000}) = 0 (0x0)
gettimeofday({1170387255.971667},0x0) = 0 (0x0)
clock_gettime(4,{372502.440960290}) = 0 (0x0)
clock_gettime(4,{372502.441027337}) = 0 (0x0)
sigprocmask(SIG_BLOCK,0x0,0x0) = 0 (0x0)
sigprocmask(SIG_SETMASK,0x0,0x0) = 0 (0x0)
SIGNAL 14 (SIGALRM)
SIGNAL 14 (SIGALRM)
sigprocmask(SIG_BLOCK,0x0,SIGHUP|SIGINT|SIGQUIT|SI GILL|SIGTRAP|SIGABRT|SIGEMT|SIGFPE|SIGBUS|SIGSEGV| SIGSYS|SIGPIPE|SIGALRM|SIGTERM|SIGURG|SIGTSTP|SIGC ONT|SIGCHLD|SIGTTIN|SIGTTOU|SIGIO|SIGXCPU|SIGXFSZ| SIGVTALRM|SIGPROF|SIGWINCH|SIGINFO|SIGUSR1|SIGUSR2 ) = 0 (0x0)
clock_gettime(4,{372502.441463426}) = 0 (0x0)
clock_gettime(4,{372502.441532430}) = 0 (0x0)
sigreturn(0x7fffffffacf0) = 3372 (0xd2c)
aio_read(0x23082f20) ERR#78 'Function not implemented'
SIGNAL 12 (SIGSYS)
SIGNAL 12 (SIGSYS)
Process stopped because of: 16


/home4 happens to be on a amr based RAID 5 logical disk, so I
tried /spare, which is a partition on my SCSI boot disk. Same
problem.

System is 6.2-STABLE amd64.

Any suggestions?

Thanks,
Bruce
--
------------------------------------------------------------------------
"I like bad!" Bruce Burden Austin, TX.
- Thuganlitha
The Power and the Prophet
Robert Don Hughes