new linux-flashplugin9 chrashes firefox - BSD

This is a discussion on new linux-flashplugin9 chrashes firefox - BSD ; Almost every page with flash kills firefox. Am I the only one? FreeBSD 6.2-RELEASE CPU: AMD Athlon(tm) 64 Processor 3500 linux-firefox-2.0.0.1 linux-flashplugin-9.0r31 -- One cannot sell the earth upon which the people walk Tacunka Witco...

+ Reply to Thread
Results 1 to 7 of 7

Thread: new linux-flashplugin9 chrashes firefox

  1. new linux-flashplugin9 chrashes firefox

    Almost every page with flash kills firefox. Am I the only one?

    FreeBSD 6.2-RELEASE
    CPU: AMD Athlon(tm) 64 Processor 3500

    linux-firefox-2.0.0.1
    linux-flashplugin-9.0r31

    --
    One cannot sell the earth upon which the people walk
    Tacunka Witco

  2. Re: new linux-flashplugin9 chrashes firefox

    In article 86d558mnfp.fsf@sparrow.local, dated Sun, 21 Jan 2007 16:03:54
    +0100, Marko Lerota wrote:

    > Almost every page with flash kills firefox. Am I the only one?
    >
    > FreeBSD 6.2-RELEASE
    > CPU: AMD Athlon(tm) 64 Processor 3500
    >
    > linux-firefox-2.0.0.1
    > linux-flashplugin-9.0r31


    Are you running a native firefox? If so, try graphics/gnash instead.
    Works for me on my amd64 box.

    HTH

    --
    Conrad J. Sabatier
    "In Unix veritas"

  3. Re: new linux-flashplugin9 chrashes firefox

    "Conrad J. Sabatier" writes:

    >> linux-firefox-2.0.0.1
    >> linux-flashplugin-9.0r31

    >
    > Are you running a native firefox? If so, try graphics/gnash instead.
    > Works for me on my amd64 box.
    >
    > HTH


    I'll try it. But if I'm the only one with this problem, then something
    is wrong with my ports. I will update them all, and see what happens
    then.

    --
    One cannot sell the earth upon which the people walk
    Tacunka Witco

  4. Re: new linux-flashplugin9 chrashes firefox

    Marko Lerota writes:

    > I'll try it. But if I'm the only one with this problem, then something
    > is wrong with my ports. I will update them all, and see what happens
    > then.


    It chrashes, it chrashes, it chrashes, again. !$@#$!@#%!@#%!@

    --
    One cannot sell the earth upon which the people walk
    Tacunka Witco

  5. Re: new linux-flashplugin9 chrashes firefox

    In article 86d553ky6p.fsf@sparrow.local, dated Thu, 25 Jan 2007 14:55:58
    +0100, Marko Lerota wrote:

    > Marko Lerota writes:
    >
    >> I'll try it. But if I'm the only one with this problem, then something
    >> is wrong with my ports. I will update them all, and see what happens
    >> then.

    >
    > It chrashes, it chrashes, it chrashes, again. !$@#$!@#%!@#%!@


    Did you install gnash from source, or from a binary package?

    I forgot to mention before that there's a problem with the port's
    Makefile, in that it specifies "USE_X_PREFIX=yes", which is wrong, since
    firefox and friends have now been converted to install under ${LOCALBASE}
    (/usr/local) instead of ${X11BASE} (/usr/X11R6). What this means is that
    the port will install the plugin under /usr/X11R6/lib/browser_plugins,
    which is *not* where firefox and pals expect to find their plugins anymore.
    A simple adjustment to the port's Makefile will take care of this problem.
    Simply change:

    USE_X_PREFIX=yes

    to

    USE_XLIB=yes

    I've submitted a PR re: this problem, but the change has yet to be
    committed, so you'll have to do the edit yourself for the time being.

    I'm just wondering how the plugin could have even been loaded, though,
    unless you did, in fact, modify the Makefile yourself before installing.
    If you didn't, then there's no way that firefox or whatever would even see
    the plugin and try to use it, so I'm wondering what might be causing the
    crashes you mentioned.

    Any further info you might provide?

    --
    Conrad J. Sabatier
    "In Unix veritas"

  6. Re: new linux-flashplugin9 chrashes firefox

    "Conrad J. Sabatier" writes:

    > I'm just wondering how the plugin could have even been loaded, though,


    No it has not been loaded. I saw there is no gnash plugin in aboutlugins,
    so I went to the linux-flashplugin again with all ports upgraded. And it's
    still crased even if I upgraded them all.

    > unless you did, in fact, modify the Makefile yourself before installing.
    > If you didn't, then there's no way that firefox or whatever would even see
    > the plugin and try to use it, so I'm wondering what might be causing the
    > crashes you mentioned.


    Now I modified the Makefile, and again it crashed.

    > Any further info you might provide?


    14:54:34: NewStream: this = 0x3432200, URL is http://something.com/combo \
    _glob/swcom_monitor/flashCombo_MP5R4.swf(m/%C5%BE)&mpref=swcom_monitor2&
    Bus error (core dumped)

    --
    One cannot sell the earth upon which the people walk
    Tacunka Witco

  7. Re: new linux-flashplugin9 chrashes firefox

    Marko Lerota writes:

    > "Conrad J. Sabatier" writes:
    >
    >> I'm just wondering how the plugin could have even been loaded, though,

    >
    > No it has not been loaded. I saw there is no gnash plugin in aboutlugins,
    > so I went to the linux-flashplugin again with all ports upgraded. And it's
    > still crased even if I upgraded them all.


    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/108077

    I was lazy to check the bugs in the ports tree. It's the known bug.

    --
    One cannot sell the earth upon which the people walk
    Tacunka Witco

+ Reply to Thread