FBSD 6.2: build of gnome2 fails - BSD

This is a discussion on FBSD 6.2: build of gnome2 fails - BSD ; Hi, I just upgraded to 6.2, did a fresh cvsup and started to build gnome2. This is the error I get: ===> Building for gail-1.9.4 gmake all-recursive gmake[1]: Entering directory `/usr/ports/accessibility/gail/work/gail-1.9.4' Making all in libgail-util gmake[2]: Entering directory `/usr/ports/accessibility/gail/work/gail-1.9.4/li ail-util' ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: FBSD 6.2: build of gnome2 fails

  1. FBSD 6.2: build of gnome2 fails

    Hi,

    I just upgraded to 6.2, did a fresh cvsup and started to build gnome2.
    This is the error I get:

    ===> Building for gail-1.9.4
    gmake all-recursive
    gmake[1]: Entering directory `/usr/ports/accessibility/gail/work/gail-1.9.4'
    Making all in libgail-util
    gmake[2]: Entering directory
    `/usr/ports/accessibility/gail/work/gail-1.9.4/li
    ail-util'
    if /bin/sh /usr/ports/accessibility/gail/work/gnome-libtool
    --mode=compile cc
    HAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    -DXUSE_MTSAFE_A
    -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    -I/usr/local/lib/g
    b-2.0/include -I/usr/local/include/gtk-2.0
    -I/usr/local/lib/gtk-2.0/include -I
    sr/local/include/cairo -I/usr/local/include/pango-1.0
    -I/usr/X11R6/include -I/
    r/local/include/freetype2 -I/usr/local/include
    -I/usr/local/include/libart-2.0
    I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    -fno-stric
    aliasing -pipe -Wall -MT gailmisc.lo -MD -MP -MF ".deps/gailmisc.Tpo" \
    -c -o gailmisc.lo `test -f 'gailmisc.c' || echo
    './'`gailmisc.c; \
    then mv -f ".deps/gailmisc.Tpo" ".deps/gailmisc.Plo"; \
    else rm -f ".deps/gailmisc.Tpo"; exit 1; \
    fi
    mkdir .libs
    cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    -DXUSE_MT
    FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    -I/usr/local
    ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    -I/usr/local/lib/gtk-2.0/incl
    e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    -I/usr/X11R6/inclu
    -I/usr/local/include/freetype2 -I/usr/local/include
    -I/usr/local/include/liba
    -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    -fno-str
    t-aliasing -pipe -Wall -MT gailmisc.lo -MD -MP -MF .deps/gailmisc.Tpo -c
    gailm
    c.c -fPIC -DPIC -o .libs/gailmisc.o
    cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    -DXUSE_MT
    FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    -I/usr/local
    ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    -I/usr/local/lib/gtk-2.0/incl
    e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    -I/usr/X11R6/inclu
    -I/usr/local/include/freetype2 -I/usr/local/include
    -I/usr/local/include/liba
    -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    -fno-str
    t-aliasing -pipe -Wall -MT gailmisc.lo -MD -MP -MF .deps/gailmisc.Tpo -c
    gailm
    c.c -o gailmisc.o >/dev/null 2>&1
    if /bin/sh /usr/ports/accessibility/gail/work/gnome-libtool
    --mode=compile cc
    HAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    -DXUSE_MTSAFE_A
    -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    -I/usr/local/lib/g
    b-2.0/include -I/usr/local/include/gtk-2.0
    -I/usr/local/lib/gtk-2.0/include -I
    sr/local/include/cairo -I/usr/local/include/pango-1.0
    -I/usr/X11R6/include -I/
    r/local/include/freetype2 -I/usr/local/include
    -I/usr/local/include/libart-2.0
    I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    -fno-stric
    aliasing -pipe -Wall -MT gailtextutil.lo -MD -MP -MF
    ".deps/gailtextutil.Tpo"
    -c -o gailtextutil.lo `test -f 'gailtextutil.c' || echo
    './'`gailtex
    til.c; \
    then mv -f ".deps/gailtextutil.Tpo" ".deps/gailtextutil.Plo"; \
    else rm -f ".deps/gailtextutil.Tpo"; exit 1; \
    fi
    cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    -DXUSE_MT
    FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    -I/usr/local
    ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    -I/usr/local/lib/gtk-2.0/incl
    e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    -I/usr/X11R6/inclu
    -I/usr/local/include/freetype2 -I/usr/local/include
    -I/usr/local/include/liba
    -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    -fno-str
    t-aliasing -pipe -Wall -MT gailtextutil.lo -MD -MP -MF
    ..deps/gailtextutil.Tpo
    gailtextutil.c -fPIC -DPIC -o .libs/gailtextutil.o
    cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    -DXUSE_MT
    FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    -I/usr/local
    ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    -I/usr/local/lib/gtk-2.0/incl
    e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    -I/usr/X11R6/inclu
    -I/usr/local/include/freetype2 -I/usr/local/include
    -I/usr/local/include/liba
    -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    -fno-str
    t-aliasing -pipe -Wall -MT gailtextutil.lo -MD -MP -MF
    ..deps/gailtextutil.Tpo
    gailtextutil.c -o gailtextutil.o >/dev/null 2>&1
    /bin/sh /usr/ports/accessibility/gail/work/gnome-libtool --mode=link cc
    -O2 -
    o-strict-aliasing -pipe -Wall -L/usr/local/lib -o libgailutil.la
    -rpath /usr
    ocal/lib -version-info 18:1:0 -L/usr/local/lib gailmisc.lo
    gailtextutil.lo -
    ,--rpath -Wl,/usr/local/lib -L/usr/local/lib -L/usr/X11R6/lib
    -lgnomecanvas-2
    art_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -lXrandr -lXi -lXinerama
    -latk-1.0 -lgd
    pixbuf-2.0 -lpangocairo-1.0 -lXcursor -lXfixes -lcairo -lpangoft2-1.0
    -lfontco
    ig -lfreetype -lz -lpango-1.0 -lm -lXrender -lX11 -lXext -lgobject-2.0
    -lgmodu
    -2.0 -lglib-2.0 -liconv
    grep: /usr/X11R6/lib/libgtk-x11-2.0.la: No such file or directory
    sed: /usr/X11R6/lib/libgtk-x11-2.0.la: No such file or directory
    gnome-libtool: link: `/usr/X11R6/lib/libgtk-x11-2.0.la' is not a valid
    libtool
    rchive
    gmake[2]: *** [libgailutil.la] Error 1
    gmake[2]: Leaving directory
    `/usr/ports/accessibility/gail/work/gail-1.9.4/lib
    il-util'
    gmake[1]: *** [all-recursive] Error 1
    gmake[1]: Leaving directory `/usr/ports/accessibility/gail/work/gail-1.9.4'
    gmake: *** [all] Error 2
    *** Error code 2

    Stop in /usr/ports/accessibility/gail.
    *** Error code 1

    Stop in /usr/ports/sysutils/gnome-control-center.
    *** Error code 1

    Stop in /usr/ports/x11/gnome-applets.
    *** Error code 1

    Stop in /usr/ports/x11/gnome2.


    Anyone an idea what's wrong?

    Thanks.

    Huub

  2. Re: FBSD 6.2: build of gnome2 fails

    Huub <"v.niekerk at hccnet.nl"> writes:

    > Hi,
    >
    > I just upgraded to 6.2, did a fresh cvsup and started to build
    > gnome2. This is the error I get:
    >
    > ===> Building for gail-1.9.4
    > gmake all-recursive
    > gmake[1]: Entering directory `/usr/ports/accessibility/gail/work/gail-1.9.4'
    > Making all in libgail-util
    > gmake[2]: Entering directory
    > /usr/ports/accessibility/gail/work/gail-1.9.4/li
    > ail-util'
    > if /bin/sh /usr/ports/accessibility/gail/work/gnome-libtool
    > --mode=compile cc
    > HAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    > -DXUSE_MTSAFE_A
    > -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    > -I/usr/local/lib/g
    > b-2.0/include -I/usr/local/include/gtk-2.0
    > -I/usr/local/lib/gtk-2.0/include -I
    > sr/local/include/cairo -I/usr/local/include/pango-1.0
    > -I/usr/X11R6/include -I/
    > r/local/include/freetype2 -I/usr/local/include
    > -I/usr/local/include/libart-2.0
    > I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    > -fno-stric
    > aliasing -pipe -Wall -MT gailmisc.lo -MD -MP -MF ".deps/gailmisc.Tpo" \
    > -c -o gailmisc.lo `test -f 'gailmisc.c' || echo
    > ./'`gailmisc.c; \
    > then mv -f ".deps/gailmisc.Tpo" ".deps/gailmisc.Plo"; \
    > else rm -f ".deps/gailmisc.Tpo"; exit 1; \
    > fi
    > mkdir .libs
    > cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    > -DXUSE_MT
    > FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    > -I/usr/local
    > ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    > -I/usr/local/lib/gtk-2.0/incl
    > e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    > -I/usr/X11R6/inclu
    > -I/usr/local/include/freetype2 -I/usr/local/include
    > -I/usr/local/include/liba
    > -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    > -fno-str
    > t-aliasing -pipe -Wall -MT gailmisc.lo -MD -MP -MF .deps/gailmisc.Tpo
    > -c
    > gailm
    > c.c -fPIC -DPIC -o .libs/gailmisc.o
    > cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    > -DXUSE_MT
    > FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    > -I/usr/local
    > ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    > -I/usr/local/lib/gtk-2.0/incl
    > e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    > -I/usr/X11R6/inclu
    > -I/usr/local/include/freetype2 -I/usr/local/include
    > -I/usr/local/include/liba
    > -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    > -fno-str
    > t-aliasing -pipe -Wall -MT gailmisc.lo -MD -MP -MF .deps/gailmisc.Tpo
    > -c
    > gailm
    > c.c -o gailmisc.o >/dev/null 2>&1
    > if /bin/sh /usr/ports/accessibility/gail/work/gnome-libtool
    > --mode=compile cc
    > HAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    > -DXUSE_MTSAFE_A
    > -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    > -I/usr/local/lib/g
    > b-2.0/include -I/usr/local/include/gtk-2.0
    > -I/usr/local/lib/gtk-2.0/include -I
    > sr/local/include/cairo -I/usr/local/include/pango-1.0
    > -I/usr/X11R6/include -I/
    > r/local/include/freetype2 -I/usr/local/include
    > -I/usr/local/include/libart-2.0
    > I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    > -fno-stric
    > aliasing -pipe -Wall -MT gailtextutil.lo -MD -MP -MF
    > ".deps/gailtextutil.Tpo"
    > -c -o gailtextutil.lo `test -f 'gailtextutil.c' || echo
    > ./'`gailtex
    > til.c; \
    > then mv -f ".deps/gailtextutil.Tpo" ".deps/gailtextutil.Plo"; \
    > else rm -f ".deps/gailtextutil.Tpo"; exit 1; \
    > fi
    > cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    > -DXUSE_MT
    > FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    > -I/usr/local
    > ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    > -I/usr/local/lib/gtk-2.0/incl
    > e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    > -I/usr/X11R6/inclu
    > -I/usr/local/include/freetype2 -I/usr/local/include
    > -I/usr/local/include/liba
    > -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    > -fno-str
    > t-aliasing -pipe -Wall -MT gailtextutil.lo -MD -MP -MF
    > .deps/gailtextutil.Tpo
    > gailtextutil.c -fPIC -DPIC -o .libs/gailtextutil.o
    > cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    > -DXUSE_MT
    > FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    > -I/usr/local
    > ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    > -I/usr/local/lib/gtk-2.0/incl
    > e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    > -I/usr/X11R6/inclu
    > -I/usr/local/include/freetype2 -I/usr/local/include
    > -I/usr/local/include/liba
    > -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    > -fno-str
    > t-aliasing -pipe -Wall -MT gailtextutil.lo -MD -MP -MF
    > .deps/gailtextutil.Tpo
    > gailtextutil.c -o gailtextutil.o >/dev/null 2>&1
    > /bin/sh /usr/ports/accessibility/gail/work/gnome-libtool --mode=link
    > cc -O2 -
    > o-strict-aliasing -pipe -Wall -L/usr/local/lib -o libgailutil.la
    > -rpath /usr
    > ocal/lib -version-info 18:1:0 -L/usr/local/lib gailmisc.lo
    > gailtextutil.lo -
    > ,--rpath -Wl,/usr/local/lib -L/usr/local/lib -L/usr/X11R6/lib
    > -lgnomecanvas-2
    > art_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -lXrandr -lXi -lXinerama
    > -latk-1.0 -lgd
    > pixbuf-2.0 -lpangocairo-1.0 -lXcursor -lXfixes -lcairo -lpangoft2-1.0
    > -lfontco
    > ig -lfreetype -lz -lpango-1.0 -lm -lXrender -lX11 -lXext -lgobject-2.0
    > -lgmodu
    > -2.0 -lglib-2.0 -liconv
    > grep: /usr/X11R6/lib/libgtk-x11-2.0.la: No such file or directory
    > sed: /usr/X11R6/lib/libgtk-x11-2.0.la: No such file or directory
    > gnome-libtool: link: `/usr/X11R6/lib/libgtk-x11-2.0.la' is not a valid
    > libtool
    > rchive
    > gmake[2]: *** [libgailutil.la] Error 1
    > gmake[2]: Leaving directory
    > /usr/ports/accessibility/gail/work/gail-1.9.4/lib
    > il-util'
    > gmake[1]: *** [all-recursive] Error 1
    > gmake[1]: Leaving directory `/usr/ports/accessibility/gail/work/gail-1.9.4'
    > gmake: *** [all] Error 2
    > *** Error code 2
    >
    > Stop in /usr/ports/accessibility/gail.
    > *** Error code 1
    >
    > Stop in /usr/ports/sysutils/gnome-control-center.
    > *** Error code 1
    >
    > Stop in /usr/ports/x11/gnome-applets.
    > *** Error code 1
    >
    > Stop in /usr/ports/x11/gnome2.
    >
    >
    > Anyone an idea what's wrong?


    Problems with your gtk installation.
    Did you update the dependencies first?
    Did you read all of the entries in UPDATING back to wherever you had
    last updated?

  3. Re: FBSD 6.2: build of gnome2 fails

    In our last episode, <44sle3c4nk.fsf@be-well.ilk.org>, the lovely and
    talented Lowell Gilbert broadcast on comp.unix.bsd.freebsd.misc:

    > Huub <"v.niekerk at hccnet.nl"> writes:


    >> Hi,
    >>
    >> I just upgraded to 6.2, did a fresh cvsup and started to build
    >> gnome2. This is the error I get:
    >>
    >> ===> Building for gail-1.9.4
    >> gmake all-recursive
    >> gmake[1]: Entering directory `/usr/ports/accessibility/gail/work/gail-1.9.4'
    >> Making all in libgail-util
    >> gmake[2]: Entering directory
    >> /usr/ports/accessibility/gail/work/gail-1.9.4/li
    >> ail-util'
    >> if /bin/sh /usr/ports/accessibility/gail/work/gnome-libtool
    >> --mode=compile cc
    >> HAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    >> -DXUSE_MTSAFE_A
    >> -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    >> -I/usr/local/lib/g
    >> b-2.0/include -I/usr/local/include/gtk-2.0
    >> -I/usr/local/lib/gtk-2.0/include -I
    >> sr/local/include/cairo -I/usr/local/include/pango-1.0
    >> -I/usr/X11R6/include -I/
    >> r/local/include/freetype2 -I/usr/local/include
    >> -I/usr/local/include/libart-2.0
    >> I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    >> -fno-stric
    >> aliasing -pipe -Wall -MT gailmisc.lo -MD -MP -MF ".deps/gailmisc.Tpo" \
    >> -c -o gailmisc.lo `test -f 'gailmisc.c' || echo
    >> ./'`gailmisc.c; \
    >> then mv -f ".deps/gailmisc.Tpo" ".deps/gailmisc.Plo"; \
    >> else rm -f ".deps/gailmisc.Tpo"; exit 1; \
    >> fi
    >> mkdir .libs
    >> cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    >> -DXUSE_MT
    >> FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    >> -I/usr/local
    >> ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    >> -I/usr/local/lib/gtk-2.0/incl
    >> e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    >> -I/usr/X11R6/inclu
    >> -I/usr/local/include/freetype2 -I/usr/local/include
    >> -I/usr/local/include/liba
    >> -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    >> -fno-str
    >> t-aliasing -pipe -Wall -MT gailmisc.lo -MD -MP -MF .deps/gailmisc.Tpo
    >> -c
    >> gailm
    >> c.c -fPIC -DPIC -o .libs/gailmisc.o
    >> cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    >> -DXUSE_MT
    >> FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    >> -I/usr/local
    >> ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    >> -I/usr/local/lib/gtk-2.0/incl
    >> e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    >> -I/usr/X11R6/inclu
    >> -I/usr/local/include/freetype2 -I/usr/local/include
    >> -I/usr/local/include/liba
    >> -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    >> -fno-str
    >> t-aliasing -pipe -Wall -MT gailmisc.lo -MD -MP -MF .deps/gailmisc.Tpo
    >> -c
    >> gailm
    >> c.c -o gailmisc.o >/dev/null 2>&1
    >> if /bin/sh /usr/ports/accessibility/gail/work/gnome-libtool
    >> --mode=compile cc
    >> HAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    >> -DXUSE_MTSAFE_A
    >> -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    >> -I/usr/local/lib/g
    >> b-2.0/include -I/usr/local/include/gtk-2.0
    >> -I/usr/local/lib/gtk-2.0/include -I
    >> sr/local/include/cairo -I/usr/local/include/pango-1.0
    >> -I/usr/X11R6/include -I/
    >> r/local/include/freetype2 -I/usr/local/include
    >> -I/usr/local/include/libart-2.0
    >> I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    >> -fno-stric
    >> aliasing -pipe -Wall -MT gailtextutil.lo -MD -MP -MF
    >> ".deps/gailtextutil.Tpo"
    >> -c -o gailtextutil.lo `test -f 'gailtextutil.c' || echo
    >> ./'`gailtex
    >> til.c; \
    >> then mv -f ".deps/gailtextutil.Tpo" ".deps/gailtextutil.Plo"; \
    >> else rm -f ".deps/gailtextutil.Tpo"; exit 1; \
    >> fi
    >> cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    >> -DXUSE_MT
    >> FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    >> -I/usr/local
    >> ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    >> -I/usr/local/lib/gtk-2.0/incl
    >> e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    >> -I/usr/X11R6/inclu
    >> -I/usr/local/include/freetype2 -I/usr/local/include
    >> -I/usr/local/include/liba
    >> -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    >> -fno-str
    >> t-aliasing -pipe -Wall -MT gailtextutil.lo -MD -MP -MF
    >> .deps/gailtextutil.Tpo
    >> gailtextutil.c -fPIC -DPIC -o .libs/gailtextutil.o
    >> cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DVERSION=\"1.9.4\" -DXTHREADS
    >> -DXUSE_MT
    >> FE_API -I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0
    >> -I/usr/local
    >> ib/glib-2.0/include -I/usr/local/include/gtk-2.0
    >> -I/usr/local/lib/gtk-2.0/incl
    >> e -I/usr/local/include/cairo -I/usr/local/include/pango-1.0
    >> -I/usr/X11R6/inclu
    >> -I/usr/local/include/freetype2 -I/usr/local/include
    >> -I/usr/local/include/liba
    >> -2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/local/include -O2
    >> -fno-str
    >> t-aliasing -pipe -Wall -MT gailtextutil.lo -MD -MP -MF
    >> .deps/gailtextutil.Tpo
    >> gailtextutil.c -o gailtextutil.o >/dev/null 2>&1
    >> /bin/sh /usr/ports/accessibility/gail/work/gnome-libtool --mode=link
    >> cc -O2 -
    >> o-strict-aliasing -pipe -Wall -L/usr/local/lib -o libgailutil.la
    >> -rpath /usr
    >> ocal/lib -version-info 18:1:0 -L/usr/local/lib gailmisc.lo
    >> gailtextutil.lo -
    >> ,--rpath -Wl,/usr/local/lib -L/usr/local/lib -L/usr/X11R6/lib
    >> -lgnomecanvas-2
    >> art_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -lXrandr -lXi -lXinerama
    >> -latk-1.0 -lgd
    >> pixbuf-2.0 -lpangocairo-1.0 -lXcursor -lXfixes -lcairo -lpangoft2-1.0
    >> -lfontco
    >> ig -lfreetype -lz -lpango-1.0 -lm -lXrender -lX11 -lXext -lgobject-2.0
    >> -lgmodu
    >> -2.0 -lglib-2.0 -liconv
    >> grep: /usr/X11R6/lib/libgtk-x11-2.0.la: No such file or directory
    >> sed: /usr/X11R6/lib/libgtk-x11-2.0.la: No such file or directory
    >> gnome-libtool: link: `/usr/X11R6/lib/libgtk-x11-2.0.la' is not a valid
    >> libtool
    >> rchive
    >> gmake[2]: *** [libgailutil.la] Error 1
    >> gmake[2]: Leaving directory
    >> /usr/ports/accessibility/gail/work/gail-1.9.4/lib
    >> il-util'
    >> gmake[1]: *** [all-recursive] Error 1
    >> gmake[1]: Leaving directory `/usr/ports/accessibility/gail/work/gail-1.9.4'
    >> gmake: *** [all] Error 2
    >> *** Error code 2
    >>
    >> Stop in /usr/ports/accessibility/gail.
    >> *** Error code 1
    >>
    >> Stop in /usr/ports/sysutils/gnome-control-center.
    >> *** Error code 1
    >>
    >> Stop in /usr/ports/x11/gnome-applets.
    >> *** Error code 1
    >>
    >> Stop in /usr/ports/x11/gnome2.
    >>
    >>
    >> Anyone an idea what's wrong?


    > Problems with your gtk installation.
    > Did you update the dependencies first?
    > Did you read all of the entries in UPDATING back to wherever you had
    > last updated?

    --
    Lars Eighner
    Countdown: 729 days to go.

  4. Re: FBSD 6.2: build of gnome2 fails

    In our last episode, , the
    lovely and talented Lars Eighner broadcast on comp.unix.bsd.freebsd.misc:

    opps!

    upgrades to 2.12 required the gnome upgrade script. upgrades from
    2.12 and up can use portupgrade according to instructions in UPGRADING.
    Never attempt to upgrade ports without searching UPGRADING.

    --
    Lars Eighner
    Countdown: 729 days to go.

  5. Re: FBSD 6.2: build of gnome2 fails

    Lars Eighner wrote:
    > In our last episode, , the
    > lovely and talented Lars Eighner broadcast on comp.unix.bsd.freebsd.misc:
    >
    > opps!
    >
    > upgrades to 2.12 required the gnome upgrade script. upgrades from
    > 2.12 and up can use portupgrade according to instructions in UPGRADING.
    > Never attempt to upgrade ports without searching UPGRADING.
    >


    I know about upgrading. But until now I used fluxbox as wm, not gnome.
    So this is not an upgrade but a fresh install of gnome. I followed the
    instructions of installing gnome from the online handbook, and got the
    posted errors.
    Now I did pkgdb -Ff and then (at request from there) pkgdb -fu. The
    first portupgrade mentioned in "UPDATING gnome" returned that howl isn't
    installed. So how do I proceed from here?

+ Reply to Thread