[fbsd62/amd64] building mplayer and svga libs... - BSD

This is a discussion on [fbsd62/amd64] building mplayer and svga libs... - BSD ; Hi all, As everybody knows, svga libs is not supported under amd64 arch. So /var/db/ports/mplayer/options file has the line: WITHOUT_SVGALIB=true Nevertheless, building mplayer try to build svga lib, and of course, fails. To fix this issue, I had to comment ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: [fbsd62/amd64] building mplayer and svga libs...

  1. [fbsd62/amd64] building mplayer and svga libs...


    Hi all,

    As everybody knows, svga libs is not supported under amd64 arch.

    So /var/db/ports/mplayer/options file has the line:

    WITHOUT_SVGALIB=true

    Nevertheless, building mplayer try to build svga lib, and of course, fails.

    To fix this issue, I had to comment some lines in the Makefile:
    #.if defined(WITH_SVGALIB)
    #LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
    #.else
    CONFIGURE_ARGS+= --disable-svga
    #.endif

    Note that, as I don't want aalib in mplayer,
    I have to do the same thing for it:
    #.if defined(WITH_AALIB)
    #LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
    #.else
    CONFIGURE_ARGS+= --disable-aa
    #.endif

    whereas my /var/db/ports/mplayer/options file has the line
    WITHOUT_AALIB=true

    I even did make clean rmconfig and rebuild, but unsuccessful.

    Any suggestion ?

    Thanks in advance.

    Cheers,

    --
    Fred.

  2. Re: [fbsd62/amd64] building mplayer and svga libs...

    In article <87zm8tnfmf.fsf@free.fr>, fred wrote:
    >
    >
    >
    >Hi all,
    >
    >As everybody knows, svga libs is not supported under amd64 arch.
    >
    >So /var/db/ports/mplayer/options file has the line:
    >
    >WITHOUT_SVGALIB=true
    >
    >Nevertheless, building mplayer try to build svga lib, and of course, fails.
    >
    >To fix this issue, I had to comment some lines in the Makefile:
    >#.if defined(WITH_SVGALIB)
    >#LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
    >#.else
    >CONFIGURE_ARGS+= --disable-svga
    >#.endif
    >
    >Note that, as I don't want aalib in mplayer,
    >I have to do the same thing for it:
    >#.if defined(WITH_AALIB)
    >#LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
    >#.else
    >CONFIGURE_ARGS+= --disable-aa
    >#.endif
    >
    >whereas my /var/db/ports/mplayer/options file has the line
    >WITHOUT_AALIB=true
    >
    >I even did make clean rmconfig and rebuild, but unsuccessful.
    >
    >Any suggestion ?


    This is strange. Are you sure your ports collection is up to date? Have
    you run "make config" recently under /usr/ports/multimedia/mplayer?

    I'm running amd64 here, and have never had the need to edit mplayer's
    Makefile to prevent it from pulling in either svgalib or aalib as a
    dependency. Something's definitely not right here.

    --
    Conrad J. Sabatier
    "In Unix veritas"

  3. Re: [fbsd62/amd64] building mplayer and svga libs...

    conrads@cox.net (Conrad J. Sabatier) a écrit :

    > This is strange. Are you sure your ports collection is up to date? Have
    > you run "make config" recently under /usr/ports/multimedia/mplayer?

    Strange, yes.

    My ports tree is up to date from yesterday, when I posted.
    Yes, I did run make config under multimedia/mplayer.

    > I'm running amd64 here, and have never had the need to edit mplayer's
    > Makefile to prevent it from pulling in either svgalib or aalib as a
    > dependency. Something's definitely not right here.

    Sure :-(

    How can I find out what's going on ?
    make has no debug option to log messages ?

    --
    Fred.

+ Reply to Thread