Since installing 4.4, ntpd keeps giving me syntax errors - BSD

This is a discussion on Since installing 4.4, ntpd keeps giving me syntax errors - BSD ; I just installed 4.4, and ntpd has stopped working. I used the exact same config and install procedure as what I was using before (4.2), but ntpd gives constant syntax error on boot, and afterward during testing. I've checked and ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Since installing 4.4, ntpd keeps giving me syntax errors

  1. Since installing 4.4, ntpd keeps giving me syntax errors

    I just installed 4.4, and ntpd has stopped working. I used the exact same
    config and install procedure as what I was using before (4.2), but ntpd gives
    constant syntax error on boot, and afterward during testing. I've checked and
    rechecked all the rc and conf files, but I just don't see it. pf.conf allows
    all outbound traffic from server on all interfaces, and all inbound traffic from
    internal interface. Maddening!


    # cat /etc/rc.conf.local
    ntpd_flags="" # enable NTPD server mode
    dhcpd_flags="" # enable DHCP server
    named_flags="" # enable DNS forwarding
    pf=YES # enable pf firewall
    ftpproxy_flags="" # enable ftp proxy


    # cat /etc/ntpd.conf listen on *
    servers pool.ntp.org


    # ntpd -n
    /etc/ntpd.conf:1: syntax error
    /etc/ntpd.conf:2: syntax error


    The thing that annoys me the most is that this used to work fine until I
    installed v4.4. I give up. Please make it stop


    ______________________________________________
    "In their wickedness they are blind,
    in their folly they persist."

    -= Wintergreen =-
    _____________________________________________

  2. Re: Since installing 4.4, ntpd keeps giving me syntax errors

    "Wintergreen" wrote in message
    news:toitg4t9el1bvkaob22gr8n3vq0loceoev@4ax.com...
    >I just installed 4.4, and ntpd has stopped working. I used the exact same
    > config and install procedure as what I was using before (4.2), but ntpd
    > gives
    > constant syntax error on boot, and afterward during testing. I've checked
    > and
    > rechecked all the rc and conf files, but I just don't see it. pf.conf
    > allows
    > all outbound traffic from server on all interfaces, and all inbound
    > traffic from
    > internal interface. Maddening!


    I've just installed 4.4 (not an upgrade; a bare install) with no such
    problems.

    > # cat /etc/rc.conf.local
    > ntpd_flags="" # enable NTPD server mode
    > dhcpd_flags="" # enable DHCP server
    > named_flags="" # enable DNS forwarding
    > pf=YES # enable pf firewall
    > ftpproxy_flags="" # enable ftp proxy


    Mine:
    # cat /etc/rc.conf.local
    ntpd_flags= # enabled during install

    Maybe the lack of an empty string may have a bearing on your problem...

    > # cat /etc/ntpd.conf listen on *
    > servers pool.ntp.org


    Errrr... your poor old cat . My ntpd.conf just contains comments and:
    servers pool.ntp.org

    > # ntpd -n
    > /etc/ntpd.conf:1: syntax error
    > /etc/ntpd.conf:2: syntax error


    Mine:
    # ntpd -n
    configuration OK

    > The thing that annoys me the most is that this used to work fine until I
    > installed v4.4. I give up. Please make it stop


    HTH,

    Steve
    --
    http://www.fivetrees.com



+ Reply to Thread