Help With Install - BSD

This is a discussion on Help With Install - BSD ; Hello! Sorry about ;y language but i am a French. So i just want to install gentoo with the installer, first I try with 2007.0 live cd AMD64 but I have a problem with the install (a problem known on ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Help With Install

  1. Help With Install

    Hello!

    Sorry about ;y language but i am a French.

    So i just want to install gentoo with the installer, first I try with 2007.0 live cd AMD64 but I have a problem with the install (a problem known on this forum)
    I decided to try 2008 livecd, and all perfectly work and that emerge.

    But at a moment the installer say me failed and this is the log filem I do not know if this is a bug so i prefere post here than in the bug.gentoo !

    Code:
    GLI: April 25 2008 13:06:47 - Gentoo Linux Installer version 0.6.3
    GLI: April 25 2008 13:08:20 - Mounted mountpoint: /
    GLI: April 25 2008 13:08:20 - Created mountpoint /home
    GLI: April 25 2008 13:08:20 - Mounted mountpoint: /home
    GLI: April 25 2008 13:08:20 - Created mountpoint /mnt/donnees
    GLI: April 25 2008 13:08:20 - Mounted mountpoint: /mnt/donnees
    GLI: April 25 2008 13:15:45 - Stage3 was generated successfully
    GLI: April 25 2008 13:15:46 - Chroot environment ready.
    GLI: April 25 2008 13:16:24 - Portage tree install was custom.
    GLI: April 25 2008 13:16:25 - Make.conf configured
    GLI: April 25 2008 13:18:13 - Root Password set on the new system.
    GLI: April 25 2008 13:18:21 - Edited Config file /mnt/gentoo/etc/conf.d/clock
    GLI: April 25 2008 13:18:21 - Edited Config file /mnt/gentoo/etc/conf.d/clock
    GLI: April 25 2008 13:18:21 - Timezone set.
    GLI: April 25 2008 13:18:21 - Starting emerge_kernel, package is livecd-kernel
    GLI: April 25 2008 13:19:13 - Edited Config file /mnt/gentoo/etc/conf.d/hostname
    GLI: April 25 2008 13:19:13 - Edited Config file /mnt/gentoo/etc/conf.d/domainname
    GLI: April 25 2008 13:19:13 - ERROR! Failure adding domainname to runlevel default because it was not found!
    GLI: April 25 2008 13:19:13 - ERROR! Could not add domainname to runlevel default. returned a bad status code.
    GLI: April 25 2008 13:19:13 - Edited Config file /mnt/gentoo/etc/hosts
    GLI: April 25 2008 13:19:13 - Added net.eth0 to runlevel default
    GLI: April 25 2008 13:19:13 - Edited Config file /mnt/gentoo/etc/conf.d/net
    GLI: April 25 2008 13:19:18 - dhcpcd emerged.
    GLI: April 25 2008 13:19:34 - Added syslog-ng to runlevel default
    GLI: April 25 2008 13:19:34 - Logging daemon installed: syslog-ng
    GLI: April 25 2008 13:19:47 - Added vixie-cron to runlevel default
    GLI: April 25 2008 13:19:47 - Cron daemon installed and configured: vixie-cron
    GLI: April 25 2008 13:19:53 - Emerged the selected bootloader.
    GLI: April 25 2008 13:19:54 - Output of Kernel Names:
    /mnt/gentoo/boot/kernel-genkernel-x86_64-2.6.23-gentoo-r8

    GLI: April 25 2008 13:19:54 - Output of Initrd Names:
    /mnt/gentoo/boot/initramfs-genkernel-x86_64-2.6.23-gentoo-r8

    GLI: April 25 2008 13:19:54 - Bootloader: the three information gathering commands have been run
    GLI: April 25 2008 13:19:54 - Grub installed and configured. Contents of grub.conf:
    default 0
    timeout 30
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    title=Gentoo Linux
    root (hd0,0)
    kernel /boot/kernel-genkernel-x86_64-2.6.23-gentoo-r8 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda1
    initrd /boot/initramfs-genkernel-x86_64-2.6.23-gentoo-r8

    GLI: April 25 2008 13:19:54 - Grub has not yet been run. If a normal install, it will now be run.
    GLI: April 25 2008 13:19:55 - Bootloader: grub has been installed!
    GLI: April 25 2008 13:21:57 - User lethys was added.
    GLI: April 25 2008 13:30:41 - Exception received during 'Installing additional packages.': CopyPackageToChrootError :FATAL: copy_pkg_to_chroot: Could not execute pkg_setup for x11-apps/xinit-1.0.5-r1
    GLI: April 25 2008 13:30:41 - Traceback (most recent call last):
    GLI: April 25 2008 13:30:41 - File "/opt/installer/GLIClientController.py", line 122, in run
    func()
    GLI: April 25 2008 13:30:41 - File "/opt/installer/GLIArchitectureTemplate.py", line 1329, in install_packages
    self._portage.emerge(installpackages, self._install_profile.get_grp_install())
    GLI: April 25 2008 13:30:41 - File "/opt/installer/GLIPortage.py", line 305, in emerge
    self.copy_pkg_to_chroot(pkg)
    GLI: April 25 2008 13:30:41 - File "/opt/installer/GLIPortage.py", line 222, in copy_pkg_to_chroot
    raise GLIException("CopyPackageToChrootError", 'fatal', 'copy_pkg_to_chroot', "Could not execute pkg_setup for " + package)
    GLI: April 25 2008 13:30:41 - GLIException: CopyPackageToChrootError :FATAL: copy_pkg_to_chroot: Could not execute pkg_setup for x11-apps/xinit-1.0.5-r1


    I tryed with the installer in command line and he says to me the same things about xinit "Could not execute pkg_setup for x11-apps/xinit-1.0.5-r1" but I can retry the step and it is work until at a moment it just quit whitout explain!

    Thanx you for helping me.


  2. Re: Help With Install

    Borked Pseudo Mailed wrote:
    [snip]

    > So i just want to install gentoo with the installer, first I try with

    ^^^^^^
    >
    > But at a moment the installer say me failed and this is the log filem I do
    > not know if this is a bug so i prefere post here than in the bug.gentoo !

    ^^^^^^^^
    > Code:
    > GLI: April 25 2008 13:06:47 - Gentoo Linux Installer version 0.6.3

    ^^^^^^^^^^^^
    [snip]

    First of all, this is what is called a "newsgroup" on something known
    as "Usenet". "Forum" usually is referring to some form of WWW webpage.

    Second, this "newsgroup" is for something called "FreeBSD", which you may
    learn more about here:

    http://www.freebsd.org/

    Since FreeBSD is *not* a Linux, you'd probably be better off posting
    somewhere that is associated with Linux; maybe something "Gentoo" related
    might be worth a try?

    -Jason



+ Reply to Thread