libvorbis port build failure - BSD

This is a discussion on libvorbis port build failure - BSD ; Running FreeBSD-6.2, trying to update libvorbis from the ports collection fails thus: # portupgrade libvorbis [Updating the pkgdb in /var/db/pkg ... - 436 packages found (-1 +1) (...). done] [Updating the portsdb in /usr/ports ... - 16034 port entries found ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: libvorbis port build failure

  1. libvorbis port build failure

    Running FreeBSD-6.2, trying to update libvorbis from the ports
    collection fails thus:

    # portupgrade libvorbis
    [Updating the pkgdb in /var/db/pkg ... - 436 packages
    found (-1 +1) (...). done]
    [Updating the portsdb in /usr/ports ... - 16034 port
    entries found
    ..........1000.........2000.........3000.........4 000.........5000.........6000.........7000........ .8000.........9000.........10000.........11000.... .....12000.........13000.........14000.........150 00.........16000
    ...... done]
    ---> Upgrading 'libvorbis-1.2.0,3' to 'libvorbis-1.2.0_2,3'
    (audio/libvorbis)
    ---> Building '/usr/ports/audio/libvorbis'
    ===> Cleaning for libtool-1.5.22_2
    ===> Cleaning for libogg-1.1.3,3
    ===> Cleaning for libvorbis-1.2.0_2,3
    ===> Extracting for libvorbis-1.2.0_2,3
    => MD5 Checksum OK for libvorbis-1.2.0.tar.gz.
    => SHA256 Checksum OK for libvorbis-1.2.0.tar.gz.
    ===> Patching for libvorbis-1.2.0_2,3
    ===> Applying FreeBSD patches for libvorbis-1.2.0_2,3
    1 out of 1 hunks failed--saving rejects to Makefile.in.rej
    => Patch patch-Makefile.in failed to apply cleanly.
    *** Error code 1

    Stop in /usr/ports/audio/libvorbis.
    ** Command failed [exit code 1]: /usr/bin/script -qa
    /tmp/portupgrade.35518.0 env UPGRADE_TOOL=portupgrade
    UPGRADE_PORT=libvorbis-1.2.0,3 UPGRADE_PORT_VER=1.2.0,3 make
    ** Fix the problem and try again.
    ** Listing the failed packages (*:skipped / !:failed)
    ! audio/libvorbis (libvorbis-1.2.0,3) (patch error)
    ---> Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed

    Any ideas?

  2. Re: libvorbis port build failure

    John Thompson writes:

    > Running FreeBSD-6.2, trying to update libvorbis from the ports
    > collection fails thus:
    >
    > # portupgrade libvorbis
    > [Updating the pkgdb in /var/db/pkg ... - 436 packages
    > found (-1 +1) (...). done]
    > [Updating the portsdb in /usr/ports ... - 16034 port
    > entries found
    > .........1000.........2000.........3000.........40 00.........5000.........6000.........7000......... 8000.........9000.........10000.........11000..... ....12000.........13000.........14000.........1500 0.........16000
    > ..... done]
    > ---> Upgrading 'libvorbis-1.2.0,3' to 'libvorbis-1.2.0_2,3'
    > (audio/libvorbis)
    > ---> Building '/usr/ports/audio/libvorbis'
    > ===> Cleaning for libtool-1.5.22_2
    > ===> Cleaning for libogg-1.1.3,3
    > ===> Cleaning for libvorbis-1.2.0_2,3
    > ===> Extracting for libvorbis-1.2.0_2,3
    > => MD5 Checksum OK for libvorbis-1.2.0.tar.gz.
    > => SHA256 Checksum OK for libvorbis-1.2.0.tar.gz.
    > ===> Patching for libvorbis-1.2.0_2,3
    > ===> Applying FreeBSD patches for libvorbis-1.2.0_2,3
    > 1 out of 1 hunks failed--saving rejects to Makefile.in.rej
    > => Patch patch-Makefile.in failed to apply cleanly.
    > *** Error code 1
    >
    > Stop in /usr/ports/audio/libvorbis.
    > ** Command failed [exit code 1]: /usr/bin/script -qa
    > /tmp/portupgrade.35518.0 env UPGRADE_TOOL=portupgrade
    > UPGRADE_PORT=libvorbis-1.2.0,3 UPGRADE_PORT_VER=1.2.0,3 make
    > ** Fix the problem and try again.
    > ** Listing the failed packages (*:skipped / !:failed)
    > ! audio/libvorbis (libvorbis-1.2.0,3) (patch error)
    > ---> Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
    >
    > Any ideas?


    Probably some stale patches sticking around. How did you install the
    ports tree? Did you update the tree after the initial install?

    --
    Lowell Gilbert, embedded/networking software engineer
    http://be-well.ilk.org/~lowell/

  3. Re: libvorbis port build failure

    On 2008-06-02, Lowell Gilbert wrote:

    > John Thompson writes:
    >
    >> Running FreeBSD-6.2, trying to update libvorbis from the ports
    >> collection fails thus:
    >>
    >> # portupgrade libvorbis
    >> [Updating the pkgdb in /var/db/pkg ... - 436 packages
    >> found (-1 +1) (...). done]
    >> [Updating the portsdb in /usr/ports ... - 16034 port
    >> entries found
    >> .........1000.........2000.........3000.........40 00.........5000.........6000.........7000......... 8000.........9000.........10000.........11000..... ....12000.........13000.........14000.........1500 0.........16000
    >> ..... done]
    >> ---> Upgrading 'libvorbis-1.2.0,3' to 'libvorbis-1.2.0_2,3'
    >> (audio/libvorbis)
    >> ---> Building '/usr/ports/audio/libvorbis'
    >> ===> Cleaning for libtool-1.5.22_2
    >> ===> Cleaning for libogg-1.1.3,3
    >> ===> Cleaning for libvorbis-1.2.0_2,3
    >> ===> Extracting for libvorbis-1.2.0_2,3
    >> => MD5 Checksum OK for libvorbis-1.2.0.tar.gz.
    >> => SHA256 Checksum OK for libvorbis-1.2.0.tar.gz.
    >> ===> Patching for libvorbis-1.2.0_2,3
    >> ===> Applying FreeBSD patches for libvorbis-1.2.0_2,3
    >> 1 out of 1 hunks failed--saving rejects to Makefile.in.rej
    >> => Patch patch-Makefile.in failed to apply cleanly.
    >> *** Error code 1
    >>
    >> Stop in /usr/ports/audio/libvorbis.
    >> ** Command failed [exit code 1]: /usr/bin/script -qa
    >> /tmp/portupgrade.35518.0 env UPGRADE_TOOL=portupgrade
    >> UPGRADE_PORT=libvorbis-1.2.0,3 UPGRADE_PORT_VER=1.2.0,3 make
    >> ** Fix the problem and try again.
    >> ** Listing the failed packages (*:skipped / !:failed)
    >> ! audio/libvorbis (libvorbis-1.2.0,3) (patch error)
    >> ---> Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
    >>
    >> Any ideas?


    > Probably some stale patches sticking around. How did you install the
    > ports tree? Did you update the tree after the initial install?


    Initially I tried it with my existing ports tree; after that failed, I
    wiped it and unpacked a fresh ports tarball, but it still failed.

    --

    John (john@os2.dhs.org)

  4. Re: libvorbis port build failure

    John Thompson writes:

    > On 2008-06-02, Lowell Gilbert wrote:
    >
    >> John Thompson writes:
    >>
    >>> Running FreeBSD-6.2, trying to update libvorbis from the ports
    >>> collection fails thus:
    >>>
    >>> # portupgrade libvorbis
    >>> [Updating the pkgdb in /var/db/pkg ... - 436 packages
    >>> found (-1 +1) (...). done]
    >>> [Updating the portsdb in /usr/ports ... - 16034 port
    >>> entries found
    >>> .........1000.........2000.........3000.........40 00.........5000.........6000.........7000......... 8000.........9000.........10000.........11000..... ....12000.........13000.........14000.........1500 0.........16000
    >>> ..... done]
    >>> ---> Upgrading 'libvorbis-1.2.0,3' to 'libvorbis-1.2.0_2,3'
    >>> (audio/libvorbis)
    >>> ---> Building '/usr/ports/audio/libvorbis'
    >>> ===> Cleaning for libtool-1.5.22_2
    >>> ===> Cleaning for libogg-1.1.3,3
    >>> ===> Cleaning for libvorbis-1.2.0_2,3
    >>> ===> Extracting for libvorbis-1.2.0_2,3
    >>> => MD5 Checksum OK for libvorbis-1.2.0.tar.gz.
    >>> => SHA256 Checksum OK for libvorbis-1.2.0.tar.gz.
    >>> ===> Patching for libvorbis-1.2.0_2,3
    >>> ===> Applying FreeBSD patches for libvorbis-1.2.0_2,3
    >>> 1 out of 1 hunks failed--saving rejects to Makefile.in.rej
    >>> => Patch patch-Makefile.in failed to apply cleanly.
    >>> *** Error code 1
    >>>
    >>> Stop in /usr/ports/audio/libvorbis.
    >>> ** Command failed [exit code 1]: /usr/bin/script -qa
    >>> /tmp/portupgrade.35518.0 env UPGRADE_TOOL=portupgrade
    >>> UPGRADE_PORT=libvorbis-1.2.0,3 UPGRADE_PORT_VER=1.2.0,3 make
    >>> ** Fix the problem and try again.
    >>> ** Listing the failed packages (*:skipped / !:failed)
    >>> ! audio/libvorbis (libvorbis-1.2.0,3) (patch error)
    >>> ---> Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
    >>>
    >>> Any ideas?

    >
    >> Probably some stale patches sticking around. How did you install the
    >> ports tree? Did you update the tree after the initial install?

    >
    > Initially I tried it with my existing ports tree; after that failed, I
    > wiped it and unpacked a fresh ports tarball, but it still failed.


    Well, I would suggest comparing patch-Makefile.in to what's in the
    tree; it applies properly for me here...

    --
    Lowell Gilbert, embedded/networking software engineer
    http://be-well.ilk.org/~lowell/

+ Reply to Thread