Hi,

I recently did a portupgrade of wine to wine-0.9.57.
I tried to bring up wincfg and it failed.
So I did a pkg_delete and reinstall from the port for a fresh install.
No change.
I remove the .wine in my home directory and removed wine and did another
fresh install.
No change.
I did a version upgrade and another fresh install.
No change.

Here is the information I hope to help you with:
[bhorne@Gargoyle:~, 10:15 PM, Thu Mar 13]>winecfg
wine: creating configuration directory '/home/bhorne/.wine'...
err:module:LdrInitializeThunk "gdi32.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for
L"C:\\windows\\system32\\rundll32.exe" failed, status c0000005
wine: wineprefixcreate failed while creating '/home/bhorne/.wine'.
wineserver: could not save registry branch to
/home/bhorne/.wine-QavCwG/system.reg : No such file or directory
wineserver: could not save registry branch to
/home/bhorne/.wine-QavCwG/user.reg : No such file or directory

[bhorne@Gargoyle:~, 10:15 PM, Thu Mar 13]>wine --version
wine-0.9.57

[bhorne@Gargoyle:~, 10:17 PM, Thu Mar 13]>uname -a
FreeBSD Gargoyle.brendhanhorne.com 6.3-STABLE FreeBSD 6.3-STABLE #15:
Thu Mar 13 21:33:02 EDT 2008
root@Gargoyle.brendhanhorne.com:/usr/obj/usr/src/sys/BLACKHOLE i386

The computer is a IBM Thinkpad T41

You can see another part of the wine error at bottom of the dmesg.
dmesg:
Copyright (c) 1992-2008 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.3-STABLE #15: Thu Mar 13 21:33:02 EDT 2008
root@Gargoyle.brendhanhorne.com:/usr/obj/usr/src/sys/BLACKHOLE
WARNING: debug.mpsafenet forced to 0 as aio requires Giant
WARNING: MPSAFE network stack disabled, expect reduced performance.
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) M processor 1.70GHz (1698.56-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0x6d6 Stepping = 6

Features=0xafe9f9bf
Features2=0x180
real memory = 1609957376 (1535 MB)
avail memory = 1568473088 (1495 MB)
kbd1 at kbdmux0
kqemu version 0x00010300
kqemu: KQEMU installed, max_locked_mem=781744kB.
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: on motherboard
acpi_ec0: port 0x62,0x66 on acpi0
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
cpu0: on acpi0
acpi_perf0: on cpu0
acpi_throttle0: on cpu0
acpi_lid0: on acpi0
acpi_button0: on acpi0
pcib0: port 0xcf8-0xcff on acpi0
pci0: on pcib0
agp0: mem 0xd0000000-0xdfffffff at
device 0.0 on pci0
pcib1: at device 1.0 on pci0
pci1: on pcib1
drm0: port 0x3000-0x30ff mem
0xe0000000-0xe7ffffff,0xc0100000-0xc010ffff irq 11 at device 0.0 on pci1
info: [drm] AGP at 0xd0000000 256MB
info: [drm] Initialized radeon 1.25.0 20060524
uhci0: port 0x1800-0x181f
irq 11 at device 29.0 on pci0
uhci0: [GIANT-LOCKED]
usb0: on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: port 0x1820-0x183f
irq 11 at device 29.1 on pci0
uhci1: [GIANT-LOCKED]
usb1: on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: port 0x1840-0x185f
irq 11 at device 29.2 on pci0
uhci2: [GIANT-LOCKED]
usb2: on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0: mem
0xc0000000-0xc00003ff irq 11 at device 29.7 on pci0
ehci0: [GIANT-LOCKED]
usb3: EHCI version 1.0
usb3: companion controllers, 2 ports each: usb0 usb1 usb2
usb3: on ehci0
usb3: USB revision 2.0
uhub3: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub3: 6 ports with 6 removable, self powered
pcib2: at device 30.0 on pci0
pci2: on pcib2
cbb0: mem 0xb0000000-0xb0000fff irq 11 at device
0.0 on pci2
cardbus0: on cbb0
pccard0: <16-bit PCCard bus> on cbb0
cbb1: mem 0xb1000000-0xb1000fff irq 11 at device
0.1 on pci2
cardbus1: on cbb1
pccard1: <16-bit PCCard bus> on cbb1
em0: port
0x8000-0x803f mem 0xc0220000-0xc023ffff,0xc0200000-0xc020ffff irq 11 at
device 1.0 on pci2
em0: Ethernet address: 00:11:25:2e:d7:ff
em0: [GIANT-LOCKED]
iwi0: mem 0xc0214000-0xc0214fff irq 11 at
device 2.0 on pci2
iwi0: Ethernet address: 00:0e:35:75:38:77
iwi0: [GIANT-LOCKED]
isab0: at device 31.0 on pci0
isa0: on isab0
atapci0: port
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1860-0x186f at device 31.1 on pci0
ata0: on atapci0
ata1: on atapci0
pci0: at device 31.3 (no driver attached)
pcm0: port 0x1c00-0x1cff,0x18c0-0x18ff mem
0xc0000c00-0xc0000dff,0xc0000800-0xc00008ff irq 11 at device 31.5 on pci0
pcm0:
pci0: at device 31.6 (no driver attached)
acpi_tz0: on acpi0
atkbdc0: port 0x60,0x64 irq 1 on acpi0
atkbd0: irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model Generic PS/2 mouse, device ID 0
fdc0: port 0x3f0-0x3f5,0x3f7 irq 6 drq 2
on acpi0
fdc0: [FAST]
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on
acpi0
sio0: type 8250 or not responding
ppc0: port 0x3bc-0x3be irq 7 on acpi0
ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
ppbus0: on ppc0
plip0: on ppbus0
lpt0: on ppbus0
lpt0: Interrupt-driven port
ppi0: on ppbus0
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
battery0: on acpi0
acpi_acad0: on acpi0
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
pmtimer0 on isa0
orm0: at iomem
0xc0000-0xcffff,0xd0000-0xd0fff,0xd1000-0xd1fff,0xdc000-0xdffff,0xe0000-0xeffff
on isa0
sc0: at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1698564265 Hz quality 800
Timecounters tick every 1.000 msec
ad0: 114473MB at ata0-master UDMA100
acd0: DVDROM at ata1-master UDMA33
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
cd0 at ata1 bus 0 target 0 lun 0
cd0: Removable CD-ROM SCSI-0 device
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
Trying to mount root from ufs:/dev/ad0s1a
interface ed1 Not found in bridge
interface tap0 Not found in bridge
info: [drm] Setting GART location based on new memory map
info: [drm] writeback test succeeded in 1 usecs
Warning: pid 1129 used static ldt allocation.
See the i386_set_ldt man page for more info
Warning: pid 1129 used static ldt allocation.
See the i386_set_ldt man page for more info
Warning: pid 1129 used static ldt allocation.
See the i386_set_ldt man page for more info
Warning: pid 1129 used static ldt allocation.
See the i386_set_ldt man page for more info
Warning: pid 1129 used static ldt allocation.
See the i386_set_ldt man page for more info
Warning: pid 1129 used static ldt allocation.
See the i386_set_ldt man page for more info
Warning: pid 1129 used static ldt allocation.
See the i386_set_ldt man page for more info
Warning: pid 1129 used static ldt allocation.
See the i386_set_ldt man page for more info
Warning: pid 1129 used static ldt allocation.
See the i386_set_ldt man page for more info
Warning: pid 1129 used static ldt allocation.
See the i386_set_ldt man page for more info
ad0: FAILURE - READ_DMA status=51
error=40 LBA=218699919
g_vfs_done():ad0s1f[READ(offset=109063798784, length=16384)]error = 5
vnode_pager_getpages: I/O read error
vm_fault: pager read error, pid 1125 (wine-pthread)


Thank you for you help in advance.

Sincerely,
Brendhan