Screen artifacts with 7-current, nvidia and LCD - BSD

This is a discussion on Screen artifacts with 7-current, nvidia and LCD - BSD ; I have just installed 7-current and got xorg started. I'm getting artifacts wherein on a vertical object, like the side of my fvwm2 window, I'm getting little "streaks" shooting off to the left that have the color of whatever object ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Screen artifacts with 7-current, nvidia and LCD

  1. Screen artifacts with 7-current, nvidia and LCD

    I have just installed 7-current and got xorg started. I'm getting
    artifacts wherein on a vertical object, like the side of my fvwm2
    window, I'm getting little "streaks" shooting off to the left that
    have the color of whatever object they're emanating from. In an fvwm2
    terminal window with a black background and grey85 text the streaking
    is very noticeable.

    I have an Asus MB with nForce2 chipset, Viewsonic VG2230wm monitor,
    some type of PNY nvidia-based video card (agp, 5500?) actually driving
    the card.

    Viewsonic says the sync is H = 24 - 82, V = 50 - 85. x11/nividia-
    xconfig has set these to:

    Identifier "Monitor0"
    VendorName "VSC"
    ModelName "VG2230wm"
    HorizSync 82.0 - 82.0
    VertRefresh 85.0
    Option "DPMS"
    EndSection

    I'm using x11/nvidia-settings for the driver which, in /var/db/pkg is
    nvidia-driver-169.12. Might going back to nvidia-driver-71xx or nvidia-
    driver-96xx work, or is it a settings issue? I'm coming from a CRT so
    I don't know if I'm hurting the screen.

    thanks,

    tf

  2. Re: Screen artifacts with 7-current, nvidia and LCD

    On Sun, 16 Mar 2008 19:09:19 -0700, thefronny wrote:

    > I have an Asus MB with nForce2 chipset, Viewsonic VG2230wm monitor, some
    > type of PNY nvidia-based video card (agp, 5500?) actually driving the
    > card.


    Do a search for the proper driver here:

    http://www.nvidia.com/Download/index.aspx?lang=en-us

    It that is an nForce2 chipset you appear to be out of luck with the nvidia
    binary drivers and will probably have to use the driver included with
    Xorg.




  3. Re: Screen artifacts with 7-current, nvidia and LCD

    On Mar 16, 9:44 pm, Dave Uhring wrote:
    > On Sun, 16 Mar 2008 19:09:19 -0700, thefronny wrote:
    > > I have an Asus MB with nForce2 chipset, Viewsonic VG2230wm monitor, some
    > > type of PNY nvidia-based video card (agp, 5500?) actually driving the
    > > card.

    >
    > Do a search for the proper driver here:
    >
    > http://www.nvidia.com/Download/index.aspx?lang=en-us
    >
    > It that is an nForce2 chipset you appear to be out of luck with the nvidia
    > binary drivers and will probably have to use the driver included with
    > Xorg.


    Thanks for the write-back. Right now I'm running the 71xx driver from
    ports; the image itself is completely free of artifacts but it is
    squashed vertically. I imagine it just cannot do 1680x1060. I'll check
    the nvidia link and see what I can get. Otherwise it might be time for
    a new video card, or I'll use the 96xx driver, which has a lot less
    artifacting but properly renders widescreen.

    thanks,

    tf.

+ Reply to Thread