Options for JRE on FreeBSD 7 - BSD

This is a discussion on Options for JRE on FreeBSD 7 - BSD ; What's my options for having JRE on FreeBSD 7(-STABLE)? I've tried installing diablo-jre from ports, but even this java test page crashes Firefox: http://www.java.com/en/download/help/testvm.xml...

+ Reply to Thread
Results 1 to 6 of 6

Thread: Options for JRE on FreeBSD 7

  1. Options for JRE on FreeBSD 7

    What's my options for having JRE on FreeBSD 7(-STABLE)?

    I've tried installing diablo-jre from ports, but even this
    java test page crashes Firefox:

    http://www.java.com/en/download/help/testvm.xml

  2. Re: Options for JRE on FreeBSD 7

    Lars Stokholm wrote:
    > What's my options for having JRE on FreeBSD 7(-STABLE)?
    >
    > I've tried installing diablo-jre from ports, but even this
    > java test page crashes Firefox:
    >
    > http://www.java.com/en/download/help/testvm.xml


    I don't think there are any options at present. I believe I had
    diablo-jre15 running OK on 7.0-RC1, or maybe it was one of the BETAs.
    It no longer works. Instead, I have installed diablo-jdk15, then
    jdk15, then deinstalled diablo... I still cannot log into my bank with
    this setup, but I suppose that is a problem with the bank. Otherwise,
    jdk15 passes all the tests.
    --
    Tore


  3. Re: Options for JRE on FreeBSD 7

    Tore Lund wrote:
    > Lars Stokholm wrote:
    >> What's my options for having JRE on FreeBSD 7(-STABLE)?


    > I don't think there are any options at present. I believe I had
    > diablo-jre15 running OK on 7.0-RC1, or maybe it was one of the BETAs.
    > It no longer works. Instead, I have installed diablo-jdk15, then
    > jdk15, then deinstalled diablo...


    It's not possible to install just jdk15?

    > I still cannot log into my bank with
    > this setup, but I suppose that is a problem with the bank. Otherwise,
    > jdk15 passes all the tests.


    Does that mean that JDK includes JRE?

  4. Re: Options for JRE on FreeBSD 7

    Lars Stokholm wrote:
    > Tore Lund wrote:
    >> Lars Stokholm wrote:
    >>> What's my options for having JRE on FreeBSD 7(-STABLE)?

    >
    >> I don't think there are any options at present. I believe I had
    >> diablo-jre15 running OK on 7.0-RC1, or maybe it was one of the BETAs.
    >> It no longer works. Instead, I have installed diablo-jdk15, then
    >> jdk15, then deinstalled diablo...

    >
    > It's not possible to install just jdk15?


    As I understand it, diablo is needed to build jdk15.

    >> I still cannot log into my bank with
    >> this setup, but I suppose that is a problem with the bank. Otherwise,
    >> jdk15 passes all the tests.

    >
    > Does that mean that JDK includes JRE?


    I guess one could say that JDK is JRE + development tools.

    Someone more knowledgeable about java than myself should step in if you
    have more questions.
    --
    Tore

  5. Re: Options for JRE on FreeBSD 7

    Lars Stokholm schrieb:
    > What's my options for having JRE on FreeBSD 7(-STABLE)?
    >
    > I've tried installing diablo-jre from ports, but even this
    > java test page crashes Firefox:
    >
    > http://www.java.com/en/download/help/testvm.xml



    You should be able to build JDK on 7.0
    It's not certified, but I certainly managed to build it.
    It does require the diablo-jdk (to build), but apparently it doesn't use
    any crashing APIs.

    BTW: Even on Linux, the browser-plugin doesn't work with AMD64 versions.




    Rainer

  6. Re: Options for JRE on FreeBSD 7

    Tore Lund wrote:

    > Lars Stokholm wrote:
    >> What's my options for having JRE on FreeBSD 7(-STABLE)?
    >>
    >> I've tried installing diablo-jre from ports, but even this
    >> java test page crashes Firefox:
    >>
    >> http://www.java.com/en/download/help/testvm.xml

    >
    > I don't think there are any options at present. I believe I had
    > diablo-jre15 running OK on 7.0-RC1, or maybe it was one of the BETAs.
    > It no longer works. Instead, I have installed diablo-jdk15, then
    > jdk15, then deinstalled diablo... I still cannot log into my bank with
    > this setup, but I suppose that is a problem with the bank. Otherwise,
    > jdk15 passes all the tests.


    I see jdk16 is also available, is it worth installing that instead of jdk15?

    --
    Mike Clarke

+ Reply to Thread