startx mystery - BSD

This is a discussion on startx mystery - BSD ; I have just installed 7.0-RC1. If I run startx without an .xinitrc file, I get the familiar twm screen, and everything looks normal. However, if I have an .xinitrc file - even it is empty or everything is commented out ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: startx mystery

  1. startx mystery

    I have just installed 7.0-RC1. If I run startx without an .xinitrc
    file, I get the familiar twm screen, and everything looks normal.
    However, if I have an .xinitrc file - even it is empty or everything is
    commented out - X fails to start, and I cannot find any error messages
    anywhere. This happens for root and user alike.

    I am sure I have forgotten something very simple, but what is it? TIA.
    --
    Tore

  2. Re: startx mystery

    Tore Lund wrote:
    > I have just installed 7.0-RC1. If I run startx without an .xinitrc
    > file, I get the familiar twm screen, and everything looks normal.
    > However, if I have an .xinitrc file - even it is empty or everything is
    > commented out - X fails to start, and I cannot find any error messages
    > anywhere. This happens for root and user alike.
    >
    > I am sure I have forgotten something very simple, but what is it? TIA.


    Does it not work with something executed in .xinitrc? (ex if there is an
    exec line uncommented) and is X failing back to the console, or is it
    just coming up with a black screen? I hope I can help.
    --Brian

  3. Re: startx mystery

    Brian Stinson wrote:
    > Tore Lund wrote:
    >> I have just installed 7.0-RC1. If I run startx without an .xinitrc
    >> file, I get the familiar twm screen, and everything looks normal.
    >> However, if I have an .xinitrc file - even it is empty or everything is
    >> commented out - X fails to start, and I cannot find any error messages
    >> anywhere. This happens for root and user alike.
    >>
    >> I am sure I have forgotten something very simple, but what is it? TIA.

    >
    > Does it not work with something executed in .xinitrc? (ex if there is an
    > exec line uncommented) and is X failing back to the console, or is it
    > just coming up with a black screen? I hope I can help.


    Very curious. X was the first thing I installed, hence I tried to
    startx without the line that says "exec ". I had plain
    forgotten about the need to *exec* something. Sigh...

    Thanks for helping - everything looks normal now.
    --
    Tore


+ Reply to Thread