Python 2.3.4 from the AIX Toolbox - Aix

This is a discussion on Python 2.3.4 from the AIX Toolbox - Aix ; Has anyone tried to install Python 2.3.4 from the AIX Toolbox site ( http://www-03.ibm.com/servers/aix/pr.../download.html ) ? I tried to install it on an AIX 5.3 system and it gave me these errors: The following errors occurred during installation: error: failed ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Python 2.3.4 from the AIX Toolbox

  1. Python 2.3.4 from the AIX Toolbox


    Has anyone tried to install Python 2.3.4 from the AIX Toolbox site
    ( http://www-03.ibm.com/servers/aix/pr.../download.html
    ) ?

    I tried to install it on an AIX 5.3 system and it gave me these
    errors:
    The following errors occurred during installation:
    error: failed dependencies:
    libdb-3.3.a(libdb-3.3.so.0) is needed by python-2.3.4-2
    libgdbm.a(libgdbm.so.3) is needed by python-2.3.4-2
    libreadline.a(libreadline.so.4) is needed by python-2.3.4-2

    Anyone know where can I get these missing libraries?

    Cheers!


  2. Re: Python 2.3.4 from the AIX Toolbox

    On Aug 24, 5:35 pm, shp...@yahoo.com wrote:
    > Has anyone tried to install Python 2.3.4 from the AIX Toolbox site
    > (http://www-03.ibm.com/servers/aix/pr.../download.html
    > ) ?
    >
    > I tried to install it on an AIX 5.3 system and it gave me these
    > errors:
    > The following errors occurred during installation:
    > error: failed dependencies:
    > libdb-3.3.a(libdb-3.3.so.0) is needed by python-2.3.4-2
    > libgdbm.a(libgdbm.so.3) is needed by python-2.3.4-2
    > libreadline.a(libreadline.so.4) is needed by python-2.3.4-2
    >
    > Anyone know where can I get these missing libraries?


    Sure, they are downloadable from the same place. libdb.a is part of
    the db 3.3.11 package, libgdbm.a is part of the gdbm 1.8.3 package,
    and libreadline.a is part of the readline 4.3 package.

    Now, don't you feel silly :-) ...I kid, I kid!

    You can probably get rpm to automatically download and install any
    prerequisites, but I tend to like to do it the hard way.

    John.



  3. Re: Python 2.3.4 from the AIX Toolbox

    On Aug 24, 2:56 pm, John wrote:
    > On Aug 24, 5:35 pm, shp...@yahoo.com wrote:
    >
    > > Has anyone tried to install Python 2.3.4 from the AIX Toolbox site
    > > (http://www-03.ibm.com/servers/aix/pr.../download.html
    > > ) ?

    >
    > > I tried to install it on an AIX 5.3 system and it gave me these
    > > errors:
    > > The following errors occurred during installation:
    > > error: failed dependencies:
    > > libdb-3.3.a(libdb-3.3.so.0) is needed by python-2.3.4-2
    > > libgdbm.a(libgdbm.so.3) is needed by python-2.3.4-2
    > > libreadline.a(libreadline.so.4) is needed by python-2.3.4-2

    >
    > > Anyone know where can I get these missing libraries?

    >
    > Sure, they are downloadable from the same place. libdb.a is part of
    > the db 3.3.11 package, libgdbm.a is part of the gdbm 1.8.3 package,
    > and libreadline.a is part of the readline 4.3 package.
    >
    > Now, don't you feel silly :-) ...I kid, I kid!
    >
    > You can probably get rpm to automatically download and install any
    > prerequisites, but I tend to like to do it the hard way.
    >
    > John.



    Thanks John, that did the trick!



  4. Re: Python 2.3.4 from the AIX Toolbox

    John wrote:
    > On Aug 24, 5:35 pm, shp...@yahoo.com wrote:
    >> Has anyone tried to install Python 2.3.4 from the AIX Toolbox site
    >> (http://www-03.ibm.com/servers/aix/pr.../download.html
    >> ) ?
    >>
    >> I tried to install it on an AIX 5.3 system and it gave me these
    >> errors:
    >> The following errors occurred during installation:
    >> error: failed dependencies:
    >> libdb-3.3.a(libdb-3.3.so.0) is needed by python-2.3.4-2
    >> libgdbm.a(libgdbm.so.3) is needed by python-2.3.4-2
    >> libreadline.a(libreadline.so.4) is needed by python-2.3.4-2
    >>
    >> Anyone know where can I get these missing libraries?

    >
    > Sure, they are downloadable from the same place. libdb.a is part of
    > the db 3.3.11 package, libgdbm.a is part of the gdbm 1.8.3 package,
    > and libreadline.a is part of the readline 4.3 package.
    >
    > Now, don't you feel silly :-) ...I kid, I kid!
    >
    > You can probably get rpm to automatically download and install any
    > prerequisites, but I tend to like to do it the hard way.


    Unless something changed since I went to Ubuntu, rpm on its own is unable to
    resolve and install prereqs. Things like yum add that capability on top.
    Unfortunately, I've never seen yum support on the aix download site.

+ Reply to Thread