revert to bos.rte.libpthreads 5.3.0.41 - Aix

This is a discussion on revert to bos.rte.libpthreads 5.3.0.41 - Aix ; Hi All, We have bos.rte.libpthreads 5.3.0.50, but we need to revert to 5.3.0.41 (see explanation before roasting me please). I tried, installp -acF -d ./bos.rte.libpthreads.5.3.0.41 But it tells me this is not a base fileset. Do I have to revert ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: revert to bos.rte.libpthreads 5.3.0.41

  1. revert to bos.rte.libpthreads 5.3.0.41

    Hi All,

    We have bos.rte.libpthreads 5.3.0.50, but we need to revert to
    5.3.0.41 (see explanation before roasting me please).

    I tried,

    installp -acF -d ./bos.rte.libpthreads.5.3.0.41

    But it tells me this is not a base fileset. Do I have to revert to
    the one on the CD first?

    ----------(optional) ----------

    WHAT IDIOT WOULD WANT TO DO THAT ?

    Before we knew this issue, to fix a customer problem, we linked a
    custom build of one of our binaries on a machine with
    bos.rte.libpthreads 5.3.0.50. 5.3.0.50 introduced a new symbol
    dependency __pth_init into our binary not present in earlier versions
    of bos.rte.libpthreads.

    Customer only has 5.3.0.41, and we still have many other customers on
    this or earlier. So we need to relink our code against a version of
    bos.rte.libpthreads 5.3.0.41 or earlier in order to continue to
    provide fixes.


  2. Re: revert to bos.rte.libpthreads 5.3.0.41

    On 15 Feb., 21:06, "George" wrote:
    > Hi All,
    >
    > We have bos.rte.libpthreads 5.3.0.50, but we need to revert to
    > 5.3.0.41 (see explanation before roasting me please).
    >
    > I tried,
    >
    > installp -acF -d ./bos.rte.libpthreads.5.3.0.41


    Force installations are only working on base filesets afaik. So
    install the base fileset and update to the version you need.

    hth
    Hajo


+ Reply to Thread