looking for AIX help & tester of opensource - Aix

This is a discussion on looking for AIX help & tester of opensource - Aix ; I'm looking for someone with an IBM pSeries running AIX 5.x who's willing to give my PPC RPMs (package files for Linux that can run on AIX systems - install with Smit(ty)) a try. http://www.vanheusden.com/aix/ And/or can someone check for ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: looking for AIX help & tester of opensource

  1. looking for AIX help & tester of opensource

    I'm looking for someone with an IBM pSeries running AIX 5.x who's willing to
    give my PPC RPMs (package files for Linux that can run on AIX systems -
    install with Smit(ty)) a try.
    http://www.vanheusden.com/aix/
    And/or can someone check for me if /bin/sh exists on such a platform?
    Thank you.



  2. Re: looking for AIX help & tester of opensource

    "newszilla.xs4all.nl" writes:

    > I'm looking for someone with an IBM pSeries running AIX 5.x who's willing to
    > give my PPC RPMs (package files for Linux that can run on AIX systems -
    > install with Smit(ty)) a try.


    Smitty on AIX5.1 doesn't appear to be smart enough to install RPMs.
    Your multitail package does not work with 'rpm':

    $ rpm --test --install multitail-4.2.0-1.ppc.rpm
    error: failed dependencies:
    libc.so.6 is needed by multitail-4.2.0-1
    libc.so.6(GLIBC_2.0) is needed by multitail-4.2.0-1
    libc.so.6(GLIBC_2.1) is needed by multitail-4.2.0-1
    libc.so.6(GLIBC_2.2) is needed by multitail-4.2.0-1
    libc.so.6(GLIBC_2.3) is needed by multitail-4.2.0-1
    libc.so.6(GLIBC_2.3.4) is needed by multitail-4.2.0-1
    libc.so.6(GLIBC_2.4) is needed by multitail-4.2.0-1
    libm.so.6 is needed by multitail-4.2.0-1
    libm.so.6(GLIBC_2.0) is needed by multitail-4.2.0-1
    libncurses.so.5 is needed by multitail-4.2.0-1
    libpanel.so.5 is needed by multitail-4.2.0-1
    libutil.so.1 is needed by multitail-4.2.0-1
    libutil.so.1(GLIBC_2.0) is needed by multitail-4.2.0-1

    It is *very* unlikely for anyone on AIX to have libc.so.6 installed.

    Also, your packages were compiled with --prefix=/usr
    On AIX, they are customarily built with --prefix=/opt/freeware

    > And/or can someone check for me if /bin/sh exists on such a platform?


    /bin/sh exists on *every* UNIX. But sometimes it is a really
    "dumb" shell, which will (for example) fail "export FOO=bar" syntax.

    Cheers,
    --
    In order to understand recursion you must first understand recursion.
    Remove /-nsp/ for email.

+ Reply to Thread