AIX 5.3 Files missing from new OS install - Aix

This is a discussion on AIX 5.3 Files missing from new OS install - Aix ; On a new install of AIX 5.3 I have run a tcbck -n ALL and got the following errors: 3001-020 /usr/lib/asw not found 3001-020 /usr/sbin/lcreatevg not found 3001-020 /usr/sbin/linstallpv not found Symbolic links exist for all these in /etc I've ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: AIX 5.3 Files missing from new OS install

  1. AIX 5.3 Files missing from new OS install


    On a new install of AIX 5.3 I have run a tcbck -n ALL and got the
    following errors:

    3001-020 /usr/lib/asw not found
    3001-020 /usr/sbin/lcreatevg not found
    3001-020 /usr/sbin/linstallpv not found

    Symbolic links exist for all these in /etc

    I've looked at AIX 5.2 systems to find the packages these files belong
    to and the relevant packages have been installed for the AIX 5.3
    system.

    Any ideas out there ??


  2. Re: AIX 5.3 Files missing from new OS install

    Hi,

    is this a new server with factory installed AIX5.3? You should
    mentioned to them you want AIX 5.3 with TCB installed.

    If u require TCB, you need to reinstall OS. From the main option during
    OS install, choose to install Trusted Computing base. Then only you can
    run the tcbck commands.

    stevint wrote:
    > On a new install of AIX 5.3 I have run a tcbck -n ALL and got the
    > following errors:
    >
    > 3001-020 /usr/lib/asw not found
    > 3001-020 /usr/sbin/lcreatevg not found
    > 3001-020 /usr/sbin/linstallpv not found
    >
    > Symbolic links exist for all these in /etc
    >
    > I've looked at AIX 5.2 systems to find the packages these files belong
    > to and the relevant packages have been installed for the AIX 5.3
    > system.
    >
    > Any ideas out there ??



  3. Re: AIX 5.3 Files missing from new OS install

    Hi,

    I confirm, you must activate TCB at the beginning of the installation,
    see the screen below for 32 bits hardware:

    Install Options



    1. Desktop........................................... ...............
    NONE, CDE, GNOME, KDE
    2. Enable Trusted Computing Base....................................
    No
    3. Graphics Software.......................................... ......
    Yes
    4. Documentation Services Software..................................
    Yes
    5. Enable System Backups to install any system......................
    Yes
    (Installs all devices and kernels)


    >>> 6. Install More Software




    0 Install with the current settings listed above.



    88 Help ?

    99 Previous Menu



    >>> Choice [6]:




    mrkhairy@yahoo.com wrote:
    > Hi,
    >
    > is this a new server with factory installed AIX5.3? You should
    > mentioned to them you want AIX 5.3 with TCB installed.
    >
    > If u require TCB, you need to reinstall OS. From the main option during
    > OS install, choose to install Trusted Computing base. Then only you can
    > run the tcbck commands.
    >
    > stevint wrote:
    >> On a new install of AIX 5.3 I have run a tcbck -n ALL and got the
    >> following errors:
    >>
    >> 3001-020 /usr/lib/asw not found
    >> 3001-020 /usr/sbin/lcreatevg not found
    >> 3001-020 /usr/sbin/linstallpv not found
    >>
    >> Symbolic links exist for all these in /etc
    >>
    >> I've looked at AIX 5.2 systems to find the packages these files belong
    >> to and the relevant packages have been installed for the AIX 5.3
    >> system.
    >>
    >> Any ideas out there ??

    >


  4. Re: AIX 5.3 Files missing from new OS install

    Hi

    Thanks for your responses.

    I installed AIX 5.3 on the server myself and I did enable TCB at the
    start of the install.

    My guess is that the files no longer exist as they are not needed in
    5.3 but it puzzles me as to why bos.compat.links creates links for
    these files to /etc when it installs ??

    Steve


+ Reply to Thread