Hi team,

I am new to unix,and need your advice on the below.
I am using aix5.3 and have installed make-3.82 on the server.
I need to use gmake for configuring and installing a package ,but it is giving error at the below

Code:
root@sapsrp:/usr/tmp/xymon-4.3.2
# ./configure.server


Configuration script for Xymon

This script asks a few questions and builds a Makefile to compile Xymon

Code:
Checking your make-utility
GNU make is required to build Xymon.
If it is available as "gmake", run configure as: 'MAKE=gmake ./configure.server'
I checked the code where its causing the error and tee the output

Code:
if test "$MAKE" = ""; then
MAKE=make
fi
echo "Checking your make-utility"
MAKEVER=`$MAKE -version 2>&1 | head -n 1 | awk '{print $1 " " $2}'`
if test "$MAKEVER" != "GNU Make"
then
echo "GNU make is required to build Xymon."
echo "If it is available as \"gmake\", run configure as: 'MAKE=gmake $0'"
exit 1

TEE OUTPUT
/usr/bin/gmake: Not a recognized flag: v
usage: make [-einqrst] [-k|-S] [-d[A|adg[1|2]mstv]] [-D variable] [-f makefile ] [-j [jobs]] [variable=value ...] [target ...# which gmake
Its not picking up the GNU version of make,I have alreadys set the gmake environment variable etc..


Code:
export MAKE=/usr/bin/gmake

root@sapsrp:/usr/bin
# which gmake
/usr/bin/gmake
root@sapsrp:/usr/bin
# ls -lrta *make*
-rwxr-xr-x 1 bin bin 10318 Nov 23 2004 makedev
lrwxrwxrwx 1 bin bin 20 Mar 01 2009 makekey -> /usr/ccs/bin/makekey
lrwxrwxrwx 1 root system 36 Apr 08 14:43 automake-1.11 -> ../../opt/freeware/bin/automake-1.11
lrwxrwxrwx 1 root system 31 Apr 08 14:43 automake -> ../../opt/freeware/bin/automake
-r-xr-xr-x 1 root system 106350 Apr 21 09:45 make
-r-xr-xr-x 1 root system 106350 Apr 21 09:47 gmake


# gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/opt/freeware/libexec/gcc/powerpc-ibm-aix5.3.0.0/4.6.0/lto-wrapper
Target: powerpc-ibm-aix5.3.0.0
Configured with: ../gcc-4.6.0/configure --with-as=/usr/bin/as --with-ld=/usr/bin/ld --enable-languages=c,c++,fortran --prefix=/opt/freeware --mandir=/opt/freeware/man --infodir=/opt/freeware/info --enable-threads --enable-version-specific-runtime-libs --disable-nls --enable-decimal-float=dpd --host=powerpc-ibm-aix5.3.0.0
Thread model: aix
gcc version 4.6.0 (GCC)

root@sapsrp:/
# gmake --version
gmake: Not a recognized flag: -
usage: make [-einqrst] [-k|-S] [-d[A|adg[1|2]mstv]] [-D variable] [-f makefile ] [-j [jobs]] [variable=value ...] [target ...]
root@sapsrp:/

# make --version
make: Not a recognized flag: -
usage: make [-einqrst] [-k|-S] [-d[A|adg[1|2]mstv]] [-D variable] [-f makefile ] [-j [jobs]] [variable=value ...] [target ...]
root@sapsrp:/
#
Please suggest on the above,Let me know if u need anymore info