Freeze during boot - Aix

This is a discussion on Freeze during boot - Aix ; Hi, I transfered OS(AIX 5.3 P55A LPAR) local disk to SAN disk (alt_disk_copy) everything seems OK during boot on SAN disk I am freezed with LED 554 do you know what is the problem ? Thanks in advance...

+ Reply to Thread
Results 1 to 11 of 11

Thread: Freeze during boot

  1. Freeze during boot

    Hi,

    I transfered OS(AIX 5.3 P55A LPAR) local disk to SAN disk (alt_disk_copy)
    everything seems OK
    during boot on SAN disk I am freezed with LED 554
    do you know what is the problem ?

    Thanks in advance




  2. Re: Freeze during boot

    astalavista wrote:

    > Hi,
    >
    > I transfered OS(AIX 5.3 P55A LPAR) local disk to SAN disk (alt_disk_copy)
    > everything seems OK
    > during boot on SAN disk I am freezed with LED 554
    > do you know what is the problem ?
    >
    > Thanks in advance


    You most likely have an access/permissions problem with the SAN. Take a look
    here:
    http://publib.boulder.ibm.com/infoce...pha6/diag1.htm

    Good luck and post what the actual reason was once you solve it?

    B

  3. Re: Freeze during boot

    astalavista schrieb:
    > Hi,
    >
    > I transfered OS(AIX 5.3 P55A LPAR) local disk to SAN disk (alt_disk_copy)
    > everything seems OK
    > during boot on SAN disk I am freezed with LED 554
    > do you know what is the problem ?
    >
    > Thanks in advance
    >
    >
    >

    Hi,

    to my experience in that case (migrating to SAN disk) you most likely
    are missing the appropriate SAN driver in your bootkernel ( i.e. in your
    original system). I don't know your SAN device, but if e.g you use some
    IBM devices like DS8000, SVC, then you need to customize your system
    with the appropriate driver (SDDPCM in that case).

    Regards,
    Uwe Auer

  4. Re: Freeze during boot


    >
    > You most likely have an access/permissions problem with the SAN. Take a
    > look
    > here:
    > http://publib.boulder.ibm.com/infoce...pha6/diag1.htm
    >
    > Good luck and post what the actual reason was once you solve it?


    OK but I did the alt_disk_copy with no problem
    so I would think the rights are correct ...




  5. Re: Freeze during boot


    >
    > to my experience in that case (migrating to SAN disk) you most likely are
    > missing the appropriate SAN driver in your bootkernel ( i.e. in your
    > original system). I don't know your SAN device, but if e.g you use some
    > IBM devices like DS8000, SVC, then you need to customize your system with
    > the appropriate driver (SDDPCM in that case).


    The SAN is a DMX 1000
    the boot begin and freeze on 554



  6. Re: Freeze during boot

    astalavista pisze:
    >> to my experience in that case (migrating to SAN disk) you most likely are
    >> missing the appropriate SAN driver in your bootkernel ( i.e. in your
    >> original system). I don't know your SAN device, but if e.g you use some
    >> IBM devices like DS8000, SVC, then you need to customize your system with
    >> the appropriate driver (SDDPCM in that case).

    >
    > The SAN is a DMX 1000
    > the boot begin and freeze on 554
    >
    >

    Like Uwe said - you probably don't have correct driver for boot from
    SAN. If you have EMC service contract - you can ask them which driver
    should be used. I think - OS just can't get drive access. Can you go to
    FC card BIOS when server boots? If yes - please check if you can see any
    targets at all.

    Try to troubleshoot 554 as well - e.g. using boot from CD to maintenance
    - have a look into this:

    http://www-01.ibm.com/support/docvie...hnicalBulletin

    Look at this as well:

    http://www.ibm.com/developerworks/wi.../AIXV53SANBoot

    Regards,
    Blazej

  7. Re: Freeze during boot

    astalavista schrieb:
    >> to my experience in that case (migrating to SAN disk) you most likely are
    >> missing the appropriate SAN driver in your bootkernel ( i.e. in your
    >> original system). I don't know your SAN device, but if e.g you use some
    >> IBM devices like DS8000, SVC, then you need to customize your system with
    >> the appropriate driver (SDDPCM in that case).

    >
    > The SAN is a DMX 1000
    > the boot begin and freeze on 554
    >
    >

    Hi,

    just to clarify - sorry if you already know. Starting boot (i.e. loading the
    boot kernel into RAM) from you SAN disk is a matter of System p firmware.
    Opening VGs / LV from accessible disks is a matter of boot kernel loaded. And
    that's why a missing driver in your bootkernel can cause your problem, although
    kernel could be loaded.

    From Diag Info for Mult Bus Systems:
    -------------------------------------------------------------------------------
    554 - The boot device could not be opened or read, or unable to define NFS swap
    device during network boot.
    -------------------------------------------------------------------------------

    My approach would be:
    - Get the appropriate driver for your device (I'm not familiar with EMC devices,
    but may be you need what is called "powerpath")
    - Boot to maintenance
    - Install driver
    - boosboot -ad /dev/
    - Restart

    Regards,
    Uwe Auer

  8. Re: Freeze during boot

    Uwe Auer pisze:
    > astalavista schrieb:
    >>> to my experience in that case (migrating to SAN disk) you most likely
    >>> are missing the appropriate SAN driver in your bootkernel ( i.e. in
    >>> your original system). I don't know your SAN device, but if e.g you
    >>> use some IBM devices like DS8000, SVC, then you need to customize
    >>> your system with the appropriate driver (SDDPCM in that case).

    >>
    >> The SAN is a DMX 1000
    >> the boot begin and freeze on 554
    >>
    >>

    > Hi,
    >
    > just to clarify - sorry if you already know. Starting boot (i.e. loading
    > the boot kernel into RAM) from you SAN disk is a matter of System p
    > firmware. Opening VGs / LV from accessible disks is a matter of boot
    > kernel loaded. And that's why a missing driver in your bootkernel can
    > cause your problem, although kernel could be loaded.
    >
    > From Diag Info for Mult Bus Systems:
    > -------------------------------------------------------------------------------
    >
    > 554 - The boot device could not be opened or read, or unable to define
    > NFS swap device during network boot.
    > -------------------------------------------------------------------------------
    >
    >
    > My approach would be:
    > - Get the appropriate driver for your device (I'm not familiar with EMC
    > devices, but may be you need what is called "powerpath")


    PowerPath its a multipathing software - but really its as well a driver
    with multipath functionality. If you'll use EMC PP - make sure that you
    using hdiskpowerX as booting device (where X is number corresponding to
    your LUN) --> check that with powermt display dev=all command.

    > - Boot to maintenance
    > - Install driver
    > - boosboot -ad /dev/
    > - Restart
    >
    > Regards,
    > Uwe Auer


  9. Re: Freeze during boot

    OK thanks

    >
    > just to clarify - sorry if you already know. Starting boot (i.e. loading
    > the boot kernel into RAM) from you SAN disk is a matter of System p
    > firmware. Opening VGs / LV from accessible disks is a matter of boot
    > kernel loaded. And that's why a missing driver in your bootkernel can
    > cause your problem, although kernel could be loaded.
    >
    > From Diag Info for Mult Bus Systems:
    > -------------------------------------------------------------------------------
    > 554 - The boot device could not be opened or read, or unable to define NFS
    > swap device during network boot.
    > -------------------------------------------------------------------------------
    >
    > My approach would be:
    > - Get the appropriate driver for your device (I'm not familiar with EMC
    > devices, but may be you need what is called "powerpath")
    > - Boot to maintenance
    > - Install driver
    > - boosboot -ad /dev/
    > - Restart
    >
    > Regards,
    > Uwe Auer




  10. Re: Freeze during boot

    On Oct 10, 11:06 pm, "astalavista" wrote:
    > Hi,
    >
    > I transfered OS(AIX 5.3 P55A LPAR) local disk to SAN disk (alt_disk_copy)
    > everything seems OK
    > during boot on SAN disk I am freezed with LED 554
    > do you know what is the problem ?
    >
    > Thanks in advance


    You really need a copy of this EMC doc:

    EMC PowerPath for AIX Version 2 5.1 Installation and Administration
    Guide


    It has a whole chapter on powerpath booting:

    This chapter describes how to configure a PowerPath hdiskpower
    device as the boot device for an AIX host.
    ◆ Setting up a PowerPath boot
    device ............................................... 36
    ◆ The pprootdev
    tool .................................................. ..........................
    38
    ◆ PowerPath and the bosboot
    tool.............................................. ........ 39
    ◆ Configuring a new PowerPath
    installation.................................... 40
    ◆ Configuring an existing PowerPath
    installation ........................... 42
    ◆ Adding additional
    paths............................................. ......................
    47
    ◆ Disabling PowerPath on a storage system boot device................
    48

  11. Re: Freeze during boot

    We also have a similar setup in our environment. If the server boots off a SAN disk where powerpath is enabled, we need to include the two paths of the powerdisk in the bootlist.Do a pprootdev fix, so that powerpath boot is enabled for next boot.More important, we need to check the drivers . If the drivers pertaining to a disk from which the server boots are old, we have to upgrade the drivers. If powerpath is not installed, then it could be the drivers which are not allowing the server to boot off the SAN disk.Drivers have to be checked and upgraded.

+ Reply to Thread