new lpar cant boot after mksysb restore - no hdisk - Aix

This is a discussion on new lpar cant boot after mksysb restore - no hdisk - Aix ; Hello ! I try to create a new virtual partition from mksysb ( NIM). Everything goes well till first reboot (just after mksysb is transfered to partition). When partition starts - "No os image was detected by firmware. At least ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: new lpar cant boot after mksysb restore - no hdisk

  1. new lpar cant boot after mksysb restore - no hdisk

    Hello !

    I try to create a new virtual partition from mksysb ( NIM).
    Everything goes well till first reboot (just after mksysb is
    transfered to partition).

    When partition starts - "No os image was detected by firmware. At
    least one disk in the bootlist was not found yet"
    Bootlist is empty. In sms mode if i try to choose hdisk (scsi device)
    i only see :
    U9133........-V8-C17-T1 /vdevice/vscsi@30000003
    and if I pick it, an error appears :
    SELECTED DEVICES WERE NOT DETECTED IN THE SYSTEM


    What I did - step by step procedure :
    1. [HMC] Dynamically add the virtual scsi adapter to the VIO server
    (required "no", slot 17). Save profile, change to default.
    2. [HMC] On the virtual partition profile I define an equivalent
    virtual SCSI
    adapter (required "yes", slot 17).
    3. [vio console] Run cfgdev to pick up the the new vhost on the VIO
    server.
    4. Use the mkvdev command to define a disk to the vhost.
    mkvdev -vdev hdisk7 -vadapter vhost10 -dev vhdisk7

    lsmap -a shows :
    vhost10 U9133.55A.651010H-V2-C17
    0x00000008
    VTD vhdisk7
    LUN 0x8100000000000000
    Backing device hdisk7
    Physloc U787B.001.DNWD33C-P1-C5-T1-W200600A0B80FB149-
    L5000000000000

    5. [NIM] define machine, prepare mksysb,
    6. [HMC] Activate the virtual partition in SMS. IPL install, configure
    network.
    7. Installation goes ok. It sees the hdisk !
    I have chosen "shrink file system", so at the end of installation
    process he ask to increase /tmp fs to 32000.
    I do it, and installation finishes without problems.
    8. Lpar reboots automatically ... and error appears that he can't find
    any hdisk...

    help !

    Kmet

  2. Re: new lpar cant boot after mksysb restore - no hdisk

    AIX version of mksysb and NIM - 5300-07-02-0806 (oslevel -s).

  3. Re: new lpar cant boot after mksysb restore - no hdisk

    On Feb 26, 11:34 am, Kmet wrote:
    > Hello !
    >
    > I try to create a new virtual partition from mksysb ( NIM).
    > Everything goes well till first reboot (just after mksysb is
    > transfered to partition).
    >
    > When partition starts - "No os image was detected by firmware. At
    > least one disk in the bootlist was not found yet"
    > Bootlist is empty. In sms mode if i try to choose hdisk (scsi device)
    > i only see :
    > U9133........-V8-C17-T1 /vdevice/vscsi@30000003
    > and if I pick it, an error appears :
    > SELECTED DEVICES WERE NOT DETECTED IN THE SYSTEM
    >


    no one can help me ?


+ Reply to Thread