hacmp cluster sahred VG pvid missing - Aix

This is a discussion on hacmp cluster sahred VG pvid missing - Aix ; On a two node cluster one shared VG that is part of a resource group shows pvid for all PVs on the side where it is varied on. Other node though sees pvids of rest of PVs in same shared ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: hacmp cluster sahred VG pvid missing

  1. hacmp cluster sahred VG pvid missing

    On a two node cluster one shared VG that is part of a resource group
    shows pvid for all PVs on the side where it is varied on.
    Other node though sees pvids of rest of PVs in same shared VG. But one
    PV has missing pvid.

    Please let me know how to fix this situation
    power4 AIX 5.2 hacmp 5.3


    Hope this is is clear
    and Thank you very much
    Kakira


  2. Re: hacmp cluster sahred VG pvid missing

    On Oct 18, 12:13 pm, kakir...@hotmail.com wrote:
    > On a two node cluster one shared VG that is part of a resource group
    > shows pvid for all PVs on the side where it is varied on.
    > Other node though sees pvids of rest of PVs in same shared VG. But one
    > PV has missing pvid.
    >
    > Please let me know how to fix this situation
    > power4 AIX 5.2 hacmp 5.3
    >
    > Hope this is is clear
    > and Thank you very much
    > Kakira


    I would try this (but I'm not 100% on this):
    - on the system where it does not work: remove all definitions for the
    vg, disk, PV, everything. Put it back to a blank state
    - on the system where is sees everything: make sure you specify a
    major number for your VG. This number gets a default from AIX, but
    force it.
    - on the system where it sees everything: varyoff the VG
    - on the system where it does not work: importvg will recreate the
    definitions. Specify the major number for that VG. It MUST match
    between systems

    and be carefull, this can be destructive!


  3. Re: hacmp cluster sahred VG pvid missing

    On 18 , 19:13, kakir...@hotmail.com wrote:
    > On a two node cluster one shared VG that is part of a resource group
    > shows pvid for all PVs on the side where it is varied on.
    > Other node though sees pvids of rest of PVs in same shared VG. But one
    > PV has missing pvid.
    >
    > Please let me know how to fix this situation
    > power4 AIX 5.2 hacmp 5.3
    >
    > Hope this is is clear
    > and Thank you very much
    > Kakira


    Dear Kakir,
    I soleved similar problem by
    # chdev -l hdisk3 -a pv=yes
    this command will replace the pvid in the ODM by the one from the
    physical volume it self.

    :-)



  4. Re: hacmp cluster sahred VG pvid missing

    On Oct 21, 2:00 am, aymanray...@yahoo.com wrote:
    > On 18 , 19:13, kakir...@hotmail.com wrote:
    >
    > > On a two node cluster one shared VG that is part of a resource group
    > > shows pvid for all PVs on the side where it is varied on.
    > > Other node though sees pvids of rest of PVs in same shared VG. But one
    > > PV has missing pvid.

    >
    > > Please let me know how to fix this situation
    > > power4 AIX 5.2 hacmp 5.3

    >
    > > Hope this is is clear
    > > and Thank you very much
    > > Kakira

    >
    > Dear Kakir,
    > I soleved similar problem by
    > # chdev -l hdisk3 -a pv=yes
    > this command will replace the pvid in the ODM by the one from the
    > physical volume it self.
    >
    > :-)


    Thanks Aymanray for reply
    Yes I know ths way but our storage guy has asked not to use chdev
    command as it may be risky on DS8300. But I don't know why


+ Reply to Thread